0

So, I've just installed Ubuntu 18.04 in a Dell G3 15 3590 (dual boot with win10) and I'm not being able to enable my sound. The only output shown is Dummy Output and in pavucontrol the profile selected is Off and the other profiles listed show "unpluggled". I have already tried a lot of solutions from people with similar problem, but none work for me. And in win10 the sound is normal.

Edit: After a lot of research and tries, I identified that Ubuntu was not loading the correct driver for my on-board audio. Someone suggested to try and older kernel, I have the 5.3.0-53 and tried the 5.3.0-28 and sound worked. The correct driver should be snd_hda_intel. However, the mic wasn't being identified. Tried other kernels, but none solve it. Then i found this topics: 18.04 audio (Realtek ALC3254) fails on new Dell G3 15 3590 and Xubuntu only shows Dummy output for audio unless I plug in a hdmi, then I can use the hdmi audio. Following it, I added snd_hda_intel.dmic_detect=0 to grub parameters, it made 5.3.0-53 kernel load the correct driver, but no mic yet. Then I added options snd-hda-intel model=headset-mic in alsa-base.conf. This made my mic being recognized correctly, however no sound are capture yet. So, I only have a partial solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.