I've installed Ubuntu 11.10 on my laptop Acer 5750. It detects wireless card and also lot of networks, but the problem is that it does not detect wireless network which is detected with my phone and another laptop (Has WinXP sp2 OS).

lspci|grep Network gives me only one line:

03:00.0 Network controller: Broadcom Corporation BCM43227 802.11b/g/n

What could be a problem ?

  • Is the network a hidden network? – OrangeTux Apr 22 '12 at 14:16
  • No, It is shown in the list of detected networks on my laptop with XP and also on my mobile phone... I also tried to 'Connect to a hidden wireless network' and entered network name, but with no results. – clzola Apr 22 '12 at 14:20
  • what security are you using? WPA, WEP,WPA2? – cprofitt Apr 22 '12 at 23:56
  • I tried all, but all of them requires to enter password so I can click Connect buton. But this network does not need password. So I choosed 'None'. – clzola Apr 23 '12 at 14:10

Use one of your other devices (XP or mobile phone) to check which channel the router is using.

If it is 12 or 13 reduce this number and check networks again - it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.