1

I have been using ubuntu 20.04 since release, I started with gdm3 and then I got the infamous login loop error which I couldn't solve without switching to Lightdm. The issue is when I switch to lightdm I am getting prompted for my password for everything. Things like mounting a usb drive, refreshing the system repositories, opening any application which requires root priveledges and even powering off the pc. Also, the unlock button to change user settings is greyed out. None of these actions required authentication when logging in with gdm3.

I also noticed that when I click the shutdown button it says there are two users logged in (both of them under my name). It seems like the only solution I can find is to switch to gdm3 which I would love to do, but I can't even get gdm3 to boot.

for gdm3 I have tried the following solutions:

  • Permissions on .Xauthority and .ICEauthority are correct
  • /tmp permissions are properly set
  • I tried removing .Xauthority and .ICEauthority
  • I tried purging and reinstalling gdm3
  • startX works from tty3 perfectly fine.

Also it may be helpful to know that I am using manually installed nvidia drivers.

If anyone has any solutions to either of these problems it would be very much appreciated.

9
  • what is happening when you enter this command sudo dpkg-reconfigure lightdm
    – UnKNOWn
    May 21 '20 at 15:30
  • @PRATAP It brings up the screen to allow me to set either gdm3 or lightdm as my default display manager. May 21 '20 at 15:44
  • so when you choose gdm3 and reboot whats happening?
    – UnKNOWn
    May 21 '20 at 15:45
  • @PRATAP It boots to gdm3 and when I enter my password it brings me back to the gdm login screen. May 21 '20 at 15:48
  • I am sorry if you have already gone through this post.. askubuntu.com/q/949456
    – UnKNOWn
    May 21 '20 at 15:51
1

I found out later that there was a bug with chrome remote desktop that prevented me from logging in. I solved this by removing the application. You could also stop the service from starting on boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.