12

I tried the shortcut Super + L nothing happens.

In the settings, have set lockdown timer for 1 min, nothings happens after that.

In the right corner menu after clicking lock item, it is showing black screen and logging me out.

gsettings get org.gnome.desktop.lockdown disable-lock-screen

shows false.

1
15

I was having EXACTLY the same problem. It turns out I have several display managers installed, and I was using lightdm instead of gdm3.

You can confirm you are using lightdm if this command works:

$ dm-tool lock

(But even if that doesn't work you may be using another display manager.)

I got the screen blanking to work properly by configuring gdm3.

Open a terminal and issue this command:

$ sudo dpkg-reconfigure gdm3

Select gdm3 in the list on the terminal, then reboot your system.

13
  • I'd like to credit Zoyolin for the suggestion to use more precise keywords, which led me to this Reddit discussion reddit.com/r/gnome/comments/c41biz/lock_screen_doesnt_work – Tommy Trussell May 21 '20 at 21:15
  • This worked for me too... but as a further question: does this mean that gdm3 is going to be more taxing on the system? – Jason Mehmel Sep 27 '20 at 3:10
  • I am not concerned about it being taxing; if the chosen display manager does not work correctly with a basic feature I think I would be concerned there might be other incompatibilities I had not found yet. I believe I have multiple display managers only because I tried different desktops, and another desktop surely works more correctly with lightdm. I don't know whether lightdm actually IS "lighter" or less taxing than gdm. – Tommy Trussell Sep 28 '20 at 3:21
  • if dm-tool lock is working for you, I would just go ahead and update the keyboard shortcut to just that. Settings > Keyboard > Application Shortcuts – lasec0203 Oct 1 '20 at 18:41
  • lxlock failed me running LXDE on top of Ubuntu MATE 20.04, dm-tool lock works. Thanks! – xebeche Oct 13 '20 at 16:49
2

I have the same gsettings get org.gnome.desktop.lockdown disable-lock-screen config and Super+L works

Could you check Settings > Keyboard Shortcuts > search(Super+L), this one should be assigned to lock the screen.

The lock is a feature of gnome-session. In your research maybe swap "ubuntu" for "gnome" or "gnome3.36.2" with a bit of luck you have the same as me ;)

1
  • 2
    Thank you for the suggested keywords -- the keyboard shortcuts part didn't help me, but searching for gnome-session did! I hope one of us helps solve the original question. – Tommy Trussell May 21 '20 at 21:16
0

Problem solved for me by going to

Settings > Screensaver > Lock Screen

and then deactivating Lock Screen.

Now everything works fine for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.