I have installed MySQL workbench from Snap Store and MySQL server 8.0 using apt. The server is running fine and I can access MySQL shell from terminal. But I am having issues connecting the Workbench to the server. I'm getting

        Cannot Connect to Database Server

Your connection attempt failed for user 'root' to the MySQL server at localhost:3306:

  An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.125" (uid=1000 pid=7944 comm="/snap/mysql-workbench-community/5/usr/bin/mysql- wo" label="snap.mysql-workbench-community.mysql-workbench- community (enforce)") interface="org.freedesktop.Secret.Service" member="OpenSession” error name="(unset)" requested_reply="0" destination=":1.13" (uid=1000 pid=2044 comm="/usr/bin/gnome- keyring-daemon --daemonize --login" label="unconfined")


1 Check that MySQL is running on address localhost

2 Check that MySQL is reachable on port 3306 (note: 3306 is the default, but this can be changed)

3 Check the user root has rights to connect to localhost from your address (MySQL rights define what clients can connect to the server and from which machines)

4 Make sure you are both providing a password if needed and using the correct password for localhost connecting from the host address you're connecting from

There no field for entering password. It shows two options store in keychain and clear. On selecting store in keychain it prompts for a password, and I enter the password. But then it shows an error:

Could not store password: An AppArmor policy prevents this sender ...

  • Just about certain that you have the dreaded MySql can't connect with a password. See step 3 on this page. Try it. digitalocean.com/community/tutorials/… May 21, 2020 at 9:35
  • 1
    FYI: MySQL Workbench's Snap package isn't officially maintained by MySQL while the debs are.
    – Kulfy
    May 21, 2020 at 11:49
  • I'm running Ubuntu 20.10 (I like to use latest, but I often can't switch right away because of GPU driver issues) so I can't use an officially-supported deb file right now. They only officially support 20.04 and 21.04 right now. So I tried the snap today, and ran into this.
    – Matt Welke
    May 3, 2021 at 0:22

3 Answers 3


You have installed MySQLWorkbench as a Snap package. You want to store the database password(s) in the Gnome Passwords & Keys facility.

However, a Snap package is sandboxed; it is not by default allowed to access this service. When you choose "Store in keychain" MySQLWorkbench is blocked by AppArmor.

You need to enter a command to allow this package to access the service. The command is:

sudo snap connect mysql-workbench-community:password-manager-service :password-manager-service

I got this from the discussion at this site.

  • 4
    This worked for me on ubuntu 20.10 Mar 8, 2021 at 16:00
  • this didnt work for me, I had to enter mysql as root and use:<< ALTER USER 'user'@'localhost' IDENTIFIED WITH mysql_native_password BY 'password'; then it worked. Need to point out that my user had <<auth_plugin>> activated meaning to enter mysql I had only to type mysql now I need to do mysql -p and enter my password
    – pippo1980
    Mar 11, 2021 at 19:30
  • but then worked
    – pippo1980
    Mar 11, 2021 at 19:52
  • 3
    This worked for me on Ubuntu 22.04. Thanks. May 4, 2022 at 18:04
  • 1
    @Jos thank you very much struggling all day morning both on Ubuntu 22.04 and Linux Mint 21. Until I arrived to your response. Thank you man. Much appreciated.
    – Matija
    Jan 16, 2023 at 11:04
  1. Go to Ubuntu Software.
  2. Search for mysql-workbench and click on Mysql Workbench Community.
  3. Click on Permissions.
  4. Enable Read, add, change, or remove saved password̀s and ssh-keys (if you are also using ssh keys)

To make it work I tested a different approach and went to MySQL Community Downloads.

In there, selected the operating system Ubuntu Linux, version 20.04 (x86, 64-bit) and clicked the Download button. Then, "No thanks, just start my download" and saved it. This is a .deb file that got saved in the Download folder and so, to install it,

cd ~/Downloads
sudo apt-get install ./mysql-workbench-community_8.0.20-1ubuntu20.04_amd64.deb

After installation is complete, went to Applications, opened it and the AppArmor policy error didn't show up again but couldn't still connect using the root user.

Then, tying to connect with the credentials created in the approach two, it worked just fine

MySQL Workbench connected fine in Ubuntu 20.04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .