0

I have Ubuntu 20.04 LTS installed alongside Windows 10 on Lenovo Flex laptop. The wifi works fine on Windows but when i switched to Ubuntu the wifi is not showing. I have tried many of the instructions on how to fix it but still the problem is not solved.

The output I get from lspci shows Realtek RTL8822BE wifi adapter present.

I really need my ubuntu wifi back, I have trying for 2 days to fix this problem. Thank you for the help!

  • What were you trying these ttwo days? Why don't you search for soulutions for rtl8822be? – Pilot6 May 20 at 21:06
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 May 20 at 21:08
  • 1
    A short search reveals:an answer – kanehekili May 20 at 21:12
  • my "lspci -knn | grep Net -A3; rfkill list" output this: 02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter [10ec:b822] (rev ff) Kernel modules: rtwpci 03:00.0 Non-Volatile memory controller [0108]: Intel Corporation SSD 660P Series [8086:f1a8] (rev 03) Subsystem: Intel Corporation SSD 660P Series [8086:390d] 0: hci0: Bluetooth Soft blocked: no Hard blocked: no – ARU May 20 at 21:26
  • In Ubutnu 20.04, your device is driven by the built-in driver combination rtw88 and rtwpci. Let's load it and check the log for informative clues: sudo modprobe rtwpci && dmesg | grep rtw Next, edit your question to add the result. – chili555 May 20 at 21:38