0

Intent:

I am trying to load images programmatically using cUrl, into Prestashop in a XAMP via SSH.

What I tried:

I have looked around and the issue may be on the setup of the server.

I tried to change the in the php.ini file the values of max_execution_time, memory_limit, max_input_vars, max_input_time but did not work.

I tried to ping the website where I am collecting the image:

ping brandsdistribution.com
PING brandsdistribution.com (109.233.123.248) 56(84) bytes of data.

and keeps running until I key interrupt it and it returns:

--- brandsdistribution.com ping statistics ---
135 packets transmitted, 0 received, 100% packet loss, time 137194ms

while if I ping google.com:

ping google.com
PING google.com (172.217.168.206) 56(84) bytes of data.
64 bytes from ams16s32-in-f14.1e100.net (172.217.168.206): icmp_seq=1 ttl=53 time=56.4 ms
64 bytes from ams16s32-in-f14.1e100.net (172.217.168.206): icmp_seq=2 ttl=53 time=47.6 ms
64 bytes from ams16s32-in-f14.1e100.net (172.217.168.206): icmp_seq=3 ttl=53 time=43.7 ms
64 bytes from ams16s32-in-f14.1e100.net (172.217.168.206): icmp_seq=4 ttl=53 time=80.0 ms
--- google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 43.747/56.940/80.002/14.079 ms

Question

Is this a DNS issue? how can I fix it?

Error message

(1/1) Exception
file_get_contents_curl failed to download https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg : (error code 28) Resolving timed out after 5000 milliseconds

in Tools.php line 2162
at ToolsCore::file_get_contents_curl('https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg', 5, null)

in Tools.php line 2235
at ToolsCore::file_get_contents('https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg', false, resource)

in Tools.php line 2294
at ToolsCore::copy('https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg', '/var/www/html/img/tmp/ps_importTmA1vB')

in productCreate.php line 107
at copyImg('68', '157', 'https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg', 'products', false)

in productCreate.php line 66
at addImage(object(Product), 'https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg', true)

in productCreate.php line 44
at createProduct(array('PRODUCT', '107510', 'Nike', 'W-ZoomGravity', 'BQ3203-006_W-ZoomGravity', '18', '101.00', '81.00', '57.00', 'Genere:Donna - Tipologia:Sneakers - Tomaia:materiale sintetico, materiale tessile - Interno:materiale sintetico, materiale tessile - Suola:gomma', '2.00', 'https://www.brandsdistribution.com/prod/stock_product_image_107510_1178872247.jpg', 'https://www.brandsdistribution.com/prod/stock_product_image_107510_2136019726.jpg', 'https://www.brandsdistribution.com/prod/stock_product_image_107510_1040197763.jpg', 'Vietnam', 'Nike', '', '', '', 'Scarpe', '', 'Sneakers', '', '', 'Continuativi', 'Rosa', '', 'pink,dimgray', 'Donna', '', '', '', '', ''))
in productCreate.php line 22

Spec

  • Ubuntu Server 20.04
  • PHP 7.2
  • mysql 15.1 Distrib 10.3.22-MariaDB

Edits:

  1. my nameserver is 127.0.0.53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.