7

When i do F1, the help window appear and a message alert also :

Object not accessible. The Object cannot be accessed due to insufficient user rights.

libreoffice help do not open

I understand what it means, but how could i figure out WHICH object does have insufficient permissions ?

  • Where could be the full logs ? how make them be written somewhere to be read ?
  • How could i know WHICH object or folder to fix ?
  • Full purge and reinstall of libreoffice package didn't help.
  • Default language use didn't help.
  • reintializing of user libreoffice profile didn't help.
  • help didn't help help ;-)

An hint someone please ?

  • 1
    Seems this is a bug, feel free to add yourself as affected. – mook765 May 20 at 12:20
  • Thanks mook765 ! just added a comment to backtrack here. – Vincent May 20 at 12:29
5

This is a bug 1869561, it is not solved.

Temporarily you can use the help from web browser by opening /usr/share/libreoffice/help/index.html location.

Or use newer version of LibreOffice from the official PPA:

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get install libreoffice
| improve this answer | |
  • ok thank you all. the link [file:///usr/share/libreoffice/help/index.html] is working. (and redirect to my language automatically) – Vincent May 20 at 13:42
5

A known bug. See https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1869561

According to that report a fix is in the pipeline. Meanwhile, to see help, open a browser and go to file:///usr/share/libreoffice/help/index.html

| improve this answer | |
1

Only an idea, but... the terminal command sudo dpkg -l | grep libreoffice-help should show you the name of the package where libreoffice help is located. At my laptop, there are two packages called libreoffice-help-common and libreoffice-help-en-us.

And the command locate libreoffice-help-common will show you the locations of the files.

| improve this answer | |
  • i did "sudo chmod -Rv a+r ..." on all the involved files told by the locate command. didn't change anything. – Vincent May 20 at 12:26
0

I had the same problem. Had 3 installations of Libreoffice:

  1. Snap
  2. Old Ubuntu Software Center.
  3. Deb download from libreoffice.org.

I removed all of them and killed soffice.bin in processes. Then in Software Center (Snaps) Installed fresh Libreoffice Version: 6.4.4.2

Rebooted. Now Help works with the indexed entries and no access error.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.