0

Hi I am using xubuntu with the xfce desktop. The version of ubuntu is 19.10

I have been having a lot of problems with snaps being able to access files from other sources then my main hard drive. For example a secondary internal hdd or a usb thumb drive would give me a permission denied when trying to access them. I finally did some research since I am very new to linux and still learning the ropes. I read this article to understand about setting permissions for the snaps I install. https://ubuntu.com/blog/a-guide-to-snap-permissions-and-interfaces.

I see from the article when you install the snap or look at a already installed snap in the gnome software package that there is a LAUNCH REMOVE and PERMISSIONS button. For me unfortunately there is no PERMISSIONS button. Is this something I might have done or is this by design for my operating system. Is there a fix for this if it was not by design, or what other way can I set permissions up for my snaps.

It been very frustrating since all the files I need to work with are not in my Home folder and thus are inaccessible leaving me with a very large paper weight.

Thanks in advance.

8
  • Snaps are containerized for security purposes, if they are built/run in classic mode they can have access to your file-system, however if not they will be confined and cannot go outside specific directories (snap connect can be used to increase the directories they can access, but even that has limitations). You've not given any specific details of snap so this is general information; you can look up your installed snaps to see if classic or strict - snapcraft.io/docs/snap-confinement – guiverc May 20 '20 at 7:35
  • Ty very much for your response. In regards to the snap I had many that could not connect to external or secondary drives with to remember their names but I looked in this today because I install a snap today called MINDI which is a sound file converter and could not even access the main drive. All folders including my home folders were permission denied. I will check this doc out. Now does classic put a permissions button back on the software installer? – Joan Drew May 20 '20 at 10:04
  • No, the snapcraft (a developer site to aid in creating snaps) was there for details on the type of snaps I mentioned (strict, classic, definitions & differences). The type of snap is defined by the developer, and provided when you download/install the snap (one of the things us users tend to ignore). If you type snap search mindi you'll see only a "-" in the notes section, the notes will say "Classic" if it's a classic defined snap; telling you it's a strict defined snap meaning limited rights (security is higher on that app with it denied access to parts of your file-system). – guiverc May 20 '20 at 10:27
  • I'll provide a link to an answer I wrote on chromium (web browser) on the snap connect I referenced. This allows the snap to access /mnt, /media which maybe useful for external drives.. however note the snap needs to be written in a way to allow the command to work (I don't know if mindi is written to enable the snap connect to work, but I'd try it. In my answer of course I use chromium where your command would use mindi. askubuntu.com/questions/1184357/… – guiverc May 20 '20 at 10:31
  • Tyvm @ guiverc for all your patience and explaining. I have tried to wrap my head around all this and came up short don't know why there are snap and apt and packages and blah blah lol wish it would just standardize. I tried these things and nothing really worked. – Joan Drew May 20 '20 at 10:48
0

Sadly I think I am going back to Windows everything is such a pain to accomplish here. I just installed gnome desktop and it took forever to get the desktop icons enabled but I figured it out. The icons show up like generic document icons and when you click them they fail in error. Under the desktop folder they look and work fine. Was going to re-add them to desktop which in windows is as easy as dragging or right click create shortcut. In gnome apparently its like go under the bed find that old box..and don't forget your papermate pen in case you get trapped under the bed cuz it even writes upside down. Then use this tweak tool and add these commands to the terminal window... then do more reasearch for about an hour and voila a Shortcut. grrr. I'm sad to go was excited about this OS but I cannot be spending an hour of time every time I want to customize something that should take a few seconds. Thanks again for all the help you gave anyways it was very appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.