0

I'm running 18.04 on a Intel. My computer came with Ubuntu installed and a Nvidia GeForce MX150 Graphics Card, but I've never been able to use it, as it always freezes my screen. For a year, I've been using the Intel Graphics Card instead. The problem is, I got my python3 installation really messed up and had to do a Factory Reset to be able to boot again (as unfortunately I had no backup).

Since I've had this problem in the past, I've been able to more or less reproduce the steps I've made to get my computer working with Intel Graphics. Some of them were:

Purge NVIDIA Graphics:

sudo apt-get remove --purge nvidia*

Install lightdm, as the default manager got my login screen freezing too:

sudo apt-get install lightdm

Edit grub settings so I could boot in nomodeset at least:

GRUB_CMDLINE_LINUX="mem_sleep_default=deep nomodeset"

(I believe this probably wasn't the right place to write nomodeset, but I'm not the more experienced user and thought I should remove nvidia-drm.modeset=1 from my boot settings as I didn't want anything to do with NVIDIA.)

After login with lightdm in nomodeset, I got that the used Graphics Card is llvmpipe (LLVM 9.0, 256 bits), not Intel UHD Graphics, which is the desired one.

So I've installed NVIDIA repo again (sudo add-apt-repository ppa:graphics-drivers/ppa) and also Nvidia settings for being able to prime-select intel as the Graphics Card.

My desire is to be able to boot with Intel UHD Graphics but without nomodeset. How should my grub file look like? It's currently like that:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="mem_sleep_default=deep nvidia-drm.modeset=1"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

What should I do now? Does xorg might have anything to do with it? What are the risks if I try to reinstall Xorg as in here?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.