1

I am having troubles with 2 new Ubuntu 20.04 installations. Both installed on laptops, one with AMD one with Intel CPU, so since problems are the same, it seems not to be HW specific. Futhermore one Laptop uses disk encryption, the other one not. So this might be also out of the game.

The problem:

For timers like apt-daily.timer and apt-daily-upgrade.timer the persitent flag seems not to work. Once a timer is set and the laptop is started after the timer should have been elapsed, the corresponding .service is not triggered. I checked this via journalctl -u xyz

The command systemctl list-timers shows as NEXT afterwards the boot up time + the randomized delay.

The strange thing is, this seems not to apply for all timers. E.g. fstrim.timer seems to work as expected.

Does anyone have a clue why this is happening or how I can further debug? I already set the LogLevel to debug but could not find further hints

The used systemd version is:

systemd 245 (245.4-4ubuntu3)

I also changed the timezone setting on one laptop to UTC, without any success. The same effect happened there afterwards.

Thank you for any hints or comments on how to debug.

1

I continued researching on that topic.

For testing purpose, I added an own timer, also with Persistent=true, which called the apt-daily.service unit. The timer had the same content as the the original timer unit, except the value for RandomizedDelaySec, which I set to 0. After this, the timer worked and an elapsed timer after reboot is triggers the service as well.

I also modified the original apt-daily-upgrade via drop-in and removed the value for RandomizedDelaySec, which also led to a working timer.

So either there is a bug in the above mentioned systemd version, or my understanding of the timers is still not correct.

Can someone verify this with 20.04?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.