2

I am using ubuntu 20.04 with hp laptop with rtl8723be driver. I can not connect to google when on wifi. I can access other url. Google shows this error in browser

This site can’t be reached www.google.co.in unexpectedly closed the connection.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_CLOSED

I tried to edit a file(suggested by some articles. I forgot the name of the file) and added nameserver 8.8.8.8 but it didn't work for me.

Output of cat /etc/resolv.conf

nameserver 127.0.0.53
options edns0

Output of ping -c3 8.8.8.8

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=51 time=99.1 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=51 time=67.9 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=51 time=68.6 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 67.856/78.493/99.054/14.541 ms

Output of ls -al /etc/resolv.conf

lrwxrwxrwx 1 root root 39 Jan 20 00:12 /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf

Any suggestions would be greatly appreciated!

6
  • 2
    Is ufw enabled? Try disabling it sudo ufw disable – ldias May 18 '20 at 14:48
  • 1
    @ldias I tried the command but it's still not working. Should I keep ufw disabled? – Yogi Katba May 18 '20 at 14:52
  • 2
    Please edit your question to show the result of these terminal commands: cat /etc/resolv.conf and: ping -c3 8.8.8.8 and finally: ls -al /etc/resolv.conf – chili555 May 18 '20 at 15:24
  • 1
    Look at ip route. You should have a default route pointing to your WiFi. – waltinator May 18 '20 at 16:50
  • 1
    Is the behavior the same if you put in the address bar www.google.co.in or preceded by http:// or else preceded with https:// ? – chili555 May 18 '20 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.