2

I was using Kubuntu 19.10, then switched to Ubuntu 20.04, and everything was fine. Then a situation appeared, and I had to reinstall Ubuntu in UEFI mode instead of BIOS mode. Now both mouse pointer and keyboard lag, and it's not just graphical: moving and resizing windows also lags, some letters written on the keyboard are lost. The issue is not present in the Live CD, which is super weird.

I have tried multiple things: made sure that zoom and slow keys are disabled, checked and updated drivers, nothing of it works. The only thing is that mouse and keyboard lag when they are plugged into back panel (which is I guess directly to the motherboard), when I plug those into the front panel they work perfectly.

The issue is also present in both Xorg and Wayland sessions and in the login screen, but is not present in UEFI settings menu.

Is there anything else to solve my problem?

1
  • I'm experiencing similar issues on 20.04 LTS. I have a hunch that it's USB/USB3 related, but couldn't get to the root of it yet. Please update this thread if you have resolved the issue in the meantime. Also see here: askubuntu.com/questions/1029256/…
    – Jan Groth
    Jun 29 '20 at 1:03
1

There's a vast array of problems that can cause these symptoms, and it's a pickle to understand. A good first step is checking /var/log/syslog for any unusual activity.

For me the problem were aggressive wifi-scans, about once every 1/10 sec, despite the computer being connected to a wired network. This caused the whole system to slow down, causing keyboard, mouse, audio and video lags. Deactivating wifi solved the problem.

I saw a post about QT triggering this sort of behaviour - maybe an app incorrectly polling to check for a network connection or trying to detect location. These days I'm using many Linux 'betas', for Zoom, Slack, Teams etc.

1
  • I read through the log and I found some suspicious stuff. I don't actually know if they may cause the problems: Jul 18 09:53:53 altered-pc gnome-shell[1427]: Could not create transient scope for PID 4275: GDBus.Error:org.freedesktop.DBus.Error.UnixProcessIdUnknown: Process with ID 4275 does not exist. Jul 18 09:53:53 altered-pc gnome-shell[1427]: Could not create transient scope for PID 4281: GDBus.Error:org.freedesktop.DBus.Error.UnixProcessIdUnknown: Process with ID 4281 does not exist. But no actual spamming messages exist.
    – alt3r3d
    Jul 18 '20 at 4:58
1

I was having the same problem on Ubuntu 20.04 with both mouse and keyboard connected to the same wireless USB dongle. During each session, the lag would appear after a little while, barely noticable at first, but could extend to several seconds over time. I would describe that experience as "soul crushing" :)

I tried several solutions found here and there: nothing worked.

Turns out the solution was simply to use a USB 2.0 port instead of a USB 3.0 port.

0

My workaround was to comment this line: modifier_map Mod3 {Scroll_Lock};

like this: #modifier_map Mod3 {Scroll_Lock};

in this file: sudo nano /usr/share/X11/xkb/symbols/br

also, install xserver-xorg-input-evdev: sudo apt install xserver-xorg-input-evdev

and, remove xserver-xorg-input-libinput: sudo apt remove xserver-xorg-input-libinput

reboot the machine

0

I have had the same issue (internet search brought me here) - and I just noticed that when I closed the laptop lid, it automatically switched the refresh rate to 24 Hz. When I changed Settings -> Displays -> Refresh Rate to 60Hz, the mouse lag disappeared.

0

I was able to resolve the lagging issue by changing the USB Dongle to a different USB Port and also, in Ubuntu 21.04, I navigated to

Settings -> Power-> Performance Mode (Selected)

and it worked for me.

check the settings from this picture

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.