I successfully was able to SSH into my RPi running Ubuntu Core 18.04 installed on a desktop running Ubuntu 16.04. When I attempt to do the same thing on a machine using Ubuntu for Windows 10 after generating my SSH keys, and adding them to my account, I am prompted for a password. The same steps for getting the Ubuntu 16 to ssh into Ubuntu Core were followed.

I found this instance where someone was using a VM: Ubuntu CORE SSH key

However, specifying the file location did not work.

Is there a particular reason why attempting to SSH into the Pi with Ubuntu for Windows is prompting me for a password despite having generated SSH keys while the Ubuntu 16.04 desktop does not.

  • Rephrased question with a bit more clarity.
    – Corey
    May 18 '20 at 2:27
  • I'll be able to test it in a few hours, but for now I'm not certain, as none of these steps where required for my Ubuntu Desktop to work. This question seems to tackle ssh-ing into a host that has a password. I don't believe Core has one, nor did it prompt me for one.
    – Corey
    May 18 '20 at 3:55
  • Hmmm. I found Ubuntu Core's ssh-based login to be super-easy, just like your first try. I haven't had any problems yet from any of my machines running various OS. Make your ssh-client-on-WSL a bit more verbose using the -v flag, then you can see what's going on under the hood: ssh -v ubuntu_one_login@pi_ip_address.
    – user535733
    May 18 '20 at 4:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.