I am using Ubuntu 20.04 and i own a pair of Airpod pro's.

Ubuntu detects the device but fails to pair/setup/connect. I know this because when i click it, it has a spinning logo like its attempting to connect and then it just returns back to the default "Not Set Up".

enter image description here

I have followed advice from here setting the ControllerMode, i have tried both "dual" and "le" without any success.

kay@khan:~$ sudo /etc/init.d/bluetooth status

● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-05-17 18:13:04 BST; 2s ago
       Docs: man:bluetoothd(8)
   Main PID: 2808 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18696)
     Memory: 956.0K
     CGroup: /system.slice/bluetooth.service
             └─2808 /usr/lib/bluetooth/bluetoothd

May 17 18:13:04 khan systemd[1]: Starting Bluetooth service...
May 17 18:13:04 khan bluetoothd[2808]: Bluetooth daemon 5.53
May 17 18:13:04 khan systemd[1]: Started Bluetooth service.
May 17 18:13:04 khan bluetoothd[2808]: Bluetooth management interface 1.14 initialized
May 17 18:13:04 khan bluetoothd[2808]: Endpoint registered: sender=:1.140 path=/MediaEndpoint/A2DPSink/sbc
May 17 18:13:04 khan bluetoothd[2808]: Endpoint registered: sender=:1.140 path=/MediaEndpoint/A2DPSource/sbc

Bluetooth device: https://www.amazon.co.uk/gp/product/B07FBSV1XZ/

  • 2
    A side question is there a way to clear the list of already recognized/seen devices?
    – Kay
    May 17, 2020 at 17:31
  • Hi @Kay, if my answer worked for your main question, could you accept it?
    – Stiin
    Jul 7, 2022 at 19:01

3 Answers 3


Short answer is: use ControllerMode = bredr as discussed here

For others:

  1. Set ControllerMode = bredr by editing /etc/bluetooth/main.conf file using sudo nano /etc/bluetooth/main.conf command (or another text editor of your choice)
  2. sudo /etc/init.d/bluetooth restart
  3. Try to pair again.
  • 3
    I have the same problem as the OP. This solution didn't help me. Setting mode to bredr and restarting service simply resulted in the headphones not responding to my clicks at all (click in default (dual) mode: spinning wheel that eventually times out, click in bredr mode: no response at all, not even spinning wheel). Jan 14, 2021 at 19:47
  • this solution resolved the problem for me. had to try twice but otherwise worked fine Mar 27, 2021 at 5:20
  • 1
    had same problem as @AlexanderTsepkov but connected successfully with bredr after turning off and on the bluetooth switch in the GUI Aug 17, 2021 at 5:04
  • 2
    Woah, in my case there was a # in front of ControllerMode so the variable wasn't even active in the first place! You need to uncomment that line so init won't initialize with default value! Jan 26, 2022 at 15:18
  • @Stiin ye if i remember correctly it did work at the time, so ill mark this as an answer, but now i just use the default settings and it works
    – Kay
    Jul 8, 2022 at 9:35

Steps to resolve the issue:

  1. sudo nano /etc/bluetooth/main.conf
  2. Set ControllerMode = dual

I had to set dual because my Bluetooth mouse was not being detected if I assign bredr.

With dual I can use both my wireless Bluetooth earphones as well as Bluetooth mouse simultaneously.


In my case changeing ControllerMode to "bredr" or keeping the default value on "dual" didn't work and AirPods still trying endlessly set up connection.

When i changed ControllerMode=le and restart bluetooth it will connect to pods immidietly.

All the best!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .