I attempt to copy a file from my Ubuntu 20.04 machine to an Android phone via bluetooth. I follow the instructions at https://help.ubuntu.com/stable/ubuntu-help/bluetooth-send-file.html.en The devices are paired. After selecting the file to copy to the phone, there is the message "There was an error".

How do I diagnose this?

2 Answers 2


You can see the error message using:

journalctl -r -t obexd

which for example could be:

obexd: Transfer Error: Unsupported Media Type

which indicates that the file format is not accepted by the destination device (in this case the workaround would be: zip it and send the zip file).


I try to send a file created by an app I made from Android to PC and I have the same error. I closed the APP and problem persists. If I change the name of the file the problem is solved. I don't understand what the problem is.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.