3

I'm aware this question has been asked a few times, but none of the answers did help during my 18.04 time. My mainboard is an Asus Prime H310M-AR2.0 with 3 jacks in the back for 5.1 sound. mainboad description: "Realtek ALC887 8-Channel High Definition Audio CODEC".

My system is dual boot with Windows 10 and Ubuntu LTS. Until two days ago it was 18.04, where there was stereo onl, too. Now I have upgraded to 20.04. I was told by a journalist the upgrade could possibly help, but it did not.

My speakers is a Logitech 5.1 surround system with 6 speakers and 3 jacks. Running Windows 10 I can hear all 6 speakers separately, so the hardware is definitely OK.

But Ubuntu always shows stereo and I can test front left and front right only. "PulseAudio Volume Control" only allows "Line stereo (connected)" and "Headphone (not connected)". A connected headphone works fine with stereo, b.t.w.

Is there a way to reset Ubuntu's sound system completely so that it is newly recognized? Or is such a configuration simply too "old"?

4
  • In Pulseaudio volume control GUI do you have a last tab Configuration? What is selected? Does it allow selection of a different profile to allow surround sound? Also, could you explain exactly which speakers are connected to which jacks. – codlord May 17 '20 at 15:43
  • In the configuration tab I only see 2 times "Analog Stereo" and lots of "Digital Surround (HDMI...) ..." Jacks are black into light red, green into green, orange into blue. As I said, this must be correct, since it works while running Windows 10. – Bernd P. May 17 '20 at 17:19
  • Regarding the jacks you still have not said which jack does what e.g. which does front speakers, center speakers, rear speakers, subwoofer. I'm not saying it's wrong just trying to understand your config so someone can hopefully help you. Personally I don't know as I have never dealt with this sort of multi-jack output. This is a good Pulseaudio resource though: wiki.archlinux.org/index.php/PulseAudio/Examples – codlord May 17 '20 at 18:09
  • Thank you, codlord. Sorry, the jacks are: green: front -> lime black: rear -> blue orange or yellow: sub/center -> pink That is correct for a 5.1 system according to the mainboard manual. Thanks for the link. Looks very complicated, but I'll give it a try tomorow. – Bernd P. May 18 '20 at 20:07
0

You have to edit /etc/pulse/daemon.confand define the number of channels for your sound card.

Find

; default-sample-channels = 2

Uncomment it by removing the leading ;, and change it from 2 to 6:

default-sample-channels = 6

After saving that change, kill pulseaudio by running:

pulseaudio -k

(It restarts itself after a few seconds.)

That's all.

1
  • Thanks. That did not change the pulseaudio configuration dialog. Still "Analog stereo duplex" only and lots of "Digital... (HDMI).. (not available)". I give up. – Bernd P. Jun 9 '20 at 4:50
0

Same problem here!

The answer below has just solved the problem. Now sound is coming from all 6 speakers!

https://askubuntu.com/a/767033/687814

A cowardly newbie, I didn't touch the /etc/pulse/daemon.conf file but just changed the number of channel to 6 in alsamixer on the terminal.

With a little courage, I've just tried default-sample-channels = 6 and erased the semicolon before the line as somebody instructed. Now I can see every speaker on the Settings. But the volume of the subwoofer isn't controlable. This shitty OS is eating my time and soul.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.