I've just bough a new Asus laptop (Ryzen 7 4800h, Nvidia GTX 1660ti), and I'm running into several graphic issues with Linux. As described in the title, so far, the issues are that the second screen is not detected (HDMI), and that the brightness control is not working at all (and it's killing my eyes lol).

I've tried with both nvidia-440 and nvidia-435 drivers, with no luck. At least, as opposed with Linux Mint, which I also tried, the cpu doesn't seem to be under heavy load with Ubuntu.

I have everything up to date and I've also used the autoinstall command:

sudo apt-get update && sudo apt-get upgrade -y
sudo ubuntu-drivers autoinstall

This is the output of inxi -G:

Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] driver: nvidia v: 435.21 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir driver: N/A 
           Display: x11 server: X.Org 1.20.8 driver: ati,fbdev unloaded: modesetting,nouveau,nvidia,radeon,vesa 
           resolution: 1920x1080~77Hz 
           OpenGL: renderer: llvmpipe (LLVM 9.0.1 128 bits) v: 3.3 Mesa 20.0.4 

(It shows the nvidia-435 driver because that has been my last try, but as said before, it doesn't work either with 440).

Also, the Nvidia X Server Settings panel is just blank, with the "Help" and "Quit" buttons. And clicking help just says that there's no help:

enter image description here

I also leave the output of lshw -c video just in case it's useful:

       description: VGA compatible controller
       product: TU116M [GeForce GTX 1660 Ti Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:68 memory:fb000000-fbffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:f000(size=128) memory:fc000000-fc07ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Renoir
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:05:00.0
       version: c6
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:c000(size=256) memory:fc500000-fc57ffff

And also the output of lspci | grep -A 1 -i vga:

01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation TU116 High Definition Audio Controller (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6)
05:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 1637


I could finally make the second monitor work by updating to 5.6 kernel:

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6/linux-headers-5.6.0-050600_5.6.0-050600.202003292333_all.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6/linux-image-unsigned-5.6.0-050600-generic_5.6.0-050600.202003292333_amd64.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.6/linux-modules-5.6.0-050600-generic_5.6.0-050600.202003292333_amd64.deb

sudo dpkg -i *.deb

About the screen brightness, this just works partially; the difference between the min and mix brightness is minimal.

  • I've Asus laptop (Ryzen 7 4800h, Nvidia GTX 1660ti) too and with 5.8 kernel brightness works fine. – Oli Aug 8 '20 at 15:06
  • I tried this on my Hp Zbook laptop but when i rebooted it shows "you need to load kernel first" and gets stuck, I booted into an older recovery version instead, any advice how to get rid of that? – user3710760 Sep 23 '20 at 3:57
  • What does sudo dpkg -i *.deb do? – Ducky Jan 2 at 12:59
  • @user3710760 Look at my new answer : there is a missing file in the kernel installation steep. – Oli Jan 3 at 16:59

I think there is a missing file in the previous post : linux-headers-xxx-generic Mainline kernel installation needs 4 files and not only 3.

So try 5.10.4 kernel (latest today) with :

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.10.4/amd64/linux-headers-5.10.4-051004-generic_5.10.4-051004.202012301142_amd64.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.10.4/amd64/linux-headers-5.10.4-051004_5.10.4-051004.202012301142_all.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.10.4/amd64/linux-image-unsigned-5.10.4-051004-generic_5.10.4-051004.202012301142_amd64.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.10.4/amd64/linux-modules-5.10.4-051004-generic_5.10.4-051004.202012301142_amd64.deb

sudo dpkg -i *.deb  

Not the answer you're looking for? Browse other questions tagged or ask your own question.