5

From Settings -> Privacy, I got

  • Automatic Screen lock -> turned on
  • Lock Screen on Suspend -> turned on

None of them locks my screen. But the manual lock option works fine. (I did get some error message about Auto-lock while installation)

Any thoughts on how to fix it? And I'm using lightdm instead of gnome-gdm3

6
  • Auto-lock? Is this a package you installed? – UnKNOWn May 17 '20 at 15:32
  • No. I meant the installation of ubuntu-20.04. And got an error message about auto-lock functionality but didn't understand. – MI Nayan May 19 '20 at 7:35
  • error msg you got during lightdm installation?? – UnKNOWn May 19 '20 at 7:41
  • Got error while upgrading to ubuntu-20.04 from 19.10. And by default I use lightdm. – MI Nayan May 20 '20 at 7:17
  • I am trying gnome-screensaver with my updated ubuntu-20.04/gnome/lightdm. – veo May 31 '20 at 8:01
3

Screen lock is disabled by default with lightdm on Ubuntu 18+ due security issues.

check more here:

You can check you display manager with: sudo systemctl status display-manager

If you still want to lock your screen with lightdm - you can use dm-tool lock. Also you can add it to keyboard shortcut as command (e.g. Super+L).

Switching to gdm3 helped: sudo dpkg-reconfigure gdm3

1
  • Switching to gdm3 worked. Be aware though, when you receive an error message that the switch was not successful, you need to restart. That's what did it for me. – SlideM Jul 23 '20 at 16:42
0

What's the timeout set to? Previous experience may point to a very unexpected hardware related cause which I call "mouse jitter": It could be that your mouse has a slight malfunction and 'jiggles' by itself a bit, causing your computer to stay awake. Try unplugging your mouse and see what gives.

1
  • I don't think so. – MI Nayan May 19 '20 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.