2

I have a problem similar to the one described here: 20.04: internal speaker (Audio) is not working in Ubuntu 20.04 LTS after upgrading from Ubuntu 18.04 LTS

None of the solutions posted there worked for me, also the problem is a bit different in my case.

In a summary: since I've upgraded to Ubuntu 20.04, the audio normally works for me. However, sometimes after I put my system in standby and then resume it, my audio no longer works and I see only "Dummy output" in the list of audio output devices.

Restarting the computer solves the issue for me. However, it's quite annoying that I have to restart it every time.

sudo lshw -C multimedia
  *-multimedia              
       description: Audio device
       product: GP104 High Definition Audio Controller
       vendor: NVIDIA Corporation
       physical id: 0.1
       bus info: pci@0000:01:00.1
       version: a1
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:17 memory:f7080000-f7083fff
  *-usb:0
       description: Video
       product: USB 2.0 Camera
       vendor: Sonix Technology Co., Ltd.
       physical id: 1
       bus info: usb@3:3.1
       version: 0.00
       capabilities: usb-2.00
       configuration: driver=snd-usb-audio maxpower=500mA speed=480Mbit/s
  *-multimedia
       description: Audio device
       product: 8 Series/C220 Series Chipset High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:32 memory:f7330000-f7333fff
  • What does sudo lshw -C multimedia tell you? – starkus May 17 '20 at 10:42
  • Does pulseaudio -k fix it temporarily? – starkus May 17 '20 at 10:44
  • @starkus I'vem updated my question with that detail. I will try pulseaudio -k next time I'll have the same issue (as it occurs randomly) – Francesco Borzi May 17 '20 at 12:14
  • You could echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf give a try. Further reading --> linuxuprising.com/2018/06/… – starkus May 17 '20 at 12:17
  • You can see this answer if you want to, askubuntu.com/a/1244118/1071912 – Injamul Mohammad Mollah May 27 '20 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.