So I've just installed Ubuntu 20.04 alongside with Windows 10 in my Dell G3 3590. I had the problem with linux freezing before boot and I solved it by updating the grub to mode nomodeset. However, there's this loading symbol from the Dell loading screen that keeps frozen on the screen. When I print the screen the symbol doesn't appear in the print, so I photographed it. 1 I have already activate the proprietary driver from Nvidia and also tested version 435 and 440. I tryed, also, a solution from the Askubuntu to erase on the grub the "quiet splash" line, leaving only GRUB_CMDLINE_LINUX_DEFAULT=. This really solved the problem, the system booted without the symbol, however this broke it, the applications started to crash and later I wasn't able to boot it anymore. So, what else i could do?

Edit: I was told in NvidiaDeveloper forum that the 430 driver is outdated and incompatible with a 5.4 kernel. So, I'll have to use the 440, which gives me the problem above.


NVIDIA GeForce GTX 1650 with 4GB GDDR5 graphics memory

8GB 2x4GB DDR4 2666MHz

9th Generation Intel Core i5-9300H (8MB Cache, up to 4.1 GHz, 4 cores)

  • You should be using Nvidia 430.09, and can be downloaded at geforce.com/drivers – heynnema May 17 at 13:13
  • Thank you. I uninstalled the driver using "sudo apt-get purge nvidia*" and "sudo apt-get autoremove", it made the loading symbol disappears. however I'm not being able to install the driver 430.09, it gives me the error "An error occurred while performing the step: "Building kernelmodules". See /var/log/nvidia-installer.log for details." I have already updated the linux-headers with "sudo apt-get update && sudo apt-get install linux-headers-generic" and checked for the GCC version (9.3.0). Any ideas? – Poccia May 17 at 17:44
  • Did you review /var/log/nvidia-installer.log? You're probably missing dkms or build-essential. Report back. – heynnema May 17 at 17:47
  • I'm not sure what i'm looking for in the log. However, the error starts with "In file included from /tmp/selfgz13684/NVIDIA-Linux-x86_64-430.09/kernel/nvidia/nv-instance.c:13: /tmp/selfgz13684/NVIDIA-Linux-x86_64-430.09/kernel/common/inc/nv-linux.h:1593:6: error: "NV_BUILD_MODULE_INSTANCES" is not defined, evaluates to 0 [-Werror=undef] 1593 | #if (NV_BUILD_MODULE_INSTANCES != 0)" – Poccia May 17 at 17:51
  • Paste the log at paste.ubuntu.com and let me look at it. – heynnema May 17 at 17:52

As I sad, the Nvidia Driver 430.09 is not compatible with Kernel 5.4. Than, after cleaning the driver with "sudo apt-get purge nvidia*" and "sudo apt-get autoremove" I reinstalled the driver 440 and now the loading symbol doesn't freeze anymore. I'm not sure what I did, but I solved it.

Edit: Actually, I should say that even with 430.09 installed, I couldn't boot without nomodeset parameter on grub. And this breaks the audio driver. Looks like there is some kind of incompatibility between new Dell notebooks and Ubuntu versions newer than 18.04. I returned to the 18.04 version, and now It's working pretty good.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.