0

This is a bit of a weird one.

Whenever my screen locks and my monitors power off, nvidia-settings resets the checkboxes for ForceFullCompositionPipeline and AllowGSync back to some prior state that I can't seem to change. This didn't happen in 18.04, but it did happen in 19.10 and is continuing to happen in 20.04. I have an RTX 2070 Super.

Things I've tried include changing the settings as root and making a new user and seeing if the problem persists there (the answer is "sort of" in that it resets to a different set of settings). I've also saved the settings to my xorg.conf, which gets them to apply immediately after a reboot, but they're lost as soon as the screens power off.

As of right now I have an alias that I run which sets the metamodes for me, but that's tedious to run every time I log back into my computer.

Additionally, I've been getting an error in nvidia-settings when I try to exit where it asks if I want to apply my settings, even if I've already applied them and the button is greyed out. I think the two issues might be related, but I can't prove it.

0

1st of all it makes huge difference which desktop environment you use in combination with ubuntu and nvidia! wayland, xorg, xfce or lxde?

if the monitor switch triggers the metamodes and you use gsync then you should know that gsync is not very well supported if you use it on the same xscreen0 in a multimonitor environment. its a pain to use gsync on a linux system compared to windows.

i had the same problem when trying to get gsync work, allow flipping must be flagged "on" in nvidia-settings and for use of gsync to work you should disable the composition pipeline settings! the composition pipeline settings do the same job like gsync on a software level to avoid screen tearing, stuttering etc.

i found this posts helpfull:

https://linustechtips.com/main/topic/723250-am-i-using-gsync-correctly-stutters/

https://www.reddit.com/r/linux_gaming/comments/7zluy3/state_of_linux_and_gsync/

https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/nvidia-linux/1076729-using-g-sync-compatible-on-linux-with-nvidia-s-418-30-beta-driver

2
  • I am using gsync, which, according to one of those links, will never work in my setup. Disappointing, but apparently I've been fine without it this whole time so I guess it's not that big of a deal after all. I had to disable flipping just to get to my monitor's framerate, so I was using the composition pipeline to get rid of the tearing that introduced.
    – ElTimablo
    May 22 '20 at 19:04
  • if you want to use gsync with linux, i would recomend, 2GPU cards, and configure 2 different xscreens in xorg. conf, which means the gsync monitor runs on a separate graphics card with its own xscreen
    – hjsnux
    May 23 '20 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.