4

I have a dual boot Win 10 - Ubuntu 16.04 on my PC and wanted to run Ubuntu after more than a year without using it. Choosing Ubuntu in the GRUB worked, but the initialisation process got stuck in the loading phase with the Ubuntu logo. This had already occurred in the past after major Win 10 updates and was usually fixed by running boot-repair from a live USB.

I tried running boot-repair from a live USB (Ubuntu 20.04) but it kept showing the following error :

Please create a ESP partition (>1MB, fat boot flag). This can be performed via tools such as Gparted. Then try again.

I wonder why this error appears as there is an EFI partition on sda2. More details: my boot-repair log file

Besides, I earlier managed to launch Ubuntu once by tapping e on the Ubuntu entry from the GRUB bootloader, and adding acpi=off at the end of the line linux ..., followed by CTRL+X (I assume this is more specific to my Lenovo Yoga 2 Pro laptop). Unfortunately after rebooting I could not repeat that step, and the GRUB bootloader screen has now been replaced by a grub console...

Any help would be very much appreciated !

Kind regards,

Valentin

4

2 Answers 2

5

I had a similar issue. My EFI partition had a hidden flag, for some reason. After removing that flag (using GParted) boot-repair worked.

2
  • Thank you, boot-repair worked after removing that flag
    – ValentinM
    May 19, 2020 at 7:42
  • I had to exit GRUB and then restart it after removing the hidden flag. Then it worked.
    – rhinomanj
    Jan 28, 2021 at 23:42
0

Problem

Caused because of hidden flag in your EFI partition

Solution

  1. Open terminal and type gparted. Press enter
  2. Locate your EFI partion (usually it will at the top either sda1 or sda2)
  3. Right click on the EFI partion, click on manage flags
  4. Uncheck the hidden checkbox
  5. You can now run boot-repair, apply recommened repair and it will work successfully.

That's all!

note: if boot-repair still fails after doing all the above steps. Reboot your system and try boot-repair again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.