3

(While this question may seem like a duplicate, I've tried the solutions laid out in all the other similar questions and none of them did anything for me. In addition, they were asked years ago, so I doubt they were running 20.04 anyway.)

The problem is that when I install any NVIDIA drivers (this means 440, 435, and 390, since they're the ones available from the package manager. I'm willing to try others if you think it would help, but I haven't yet), the system can't boot. I can't drop to terminal or anything either—all of the Ctrl+Alt+Fx keys just show a flashing white cursor and nothing else, and when I try to go back, I can't. The only way to get out of it is to use Sysrq+REISUB. Then I have to boot in recovery mode and execute apt purge ^nvidia to get rid of the drivers before it will let me boot again. When I am logged in (whether it's recovery mode or just the desktop) my graphics card is shown in lshw -C video and lspci as a 3D controller. Here's the exact output:

01:00.0 3D controller: NVIDIA Corporation TU117GLM [Quadro T2000 Mobile / Max-Q] (rev ff)

What I've tried so far:

  • Editing /etc/gdm3/custom.conf to uncomment WaylandEnable=False
  • Editing the grub boot to add nouveau.modeset=0
  • Adding ppa:graphics-drivers and trying to install any of their packages which are listed on launchpad.org—APT is Unable to locate package nvidia-graphics-drivers-<version>.
  • As I said, I've tried using all of the drivers available to me from APT, including the ones mentioned above and 340. When I tried 340, the computer was completely unresponsive after boot—I couldn't even use SysRq to reboot, so I had to hold the power button.
  • As suggested in the comments, I tried to remove ppa:graphics-drivers/ppa, then add it again and install the driver. The same issue occurred as when I hadn't done it.

Previously to this I've actually been able to use the GPU fully. I think it initially broke because I tried to use LightDM, but now that I've uninstalled it, the drivers still don't work.

Please help!

Some new information: I am able to log in if I use kernel version 5.3.0-51-generic. However, the graphics card is still not available for use (optirun outputs [ERROR]Cannot access secondary GPU - error: Could not load GPU driver, for example).

Software:
Ubuntu 20.04, updated from 19.10
Kernel version 5.4.0-29-generic

Hardware:
Dell Precision 5540
Intel i9-9980H
NVIDIA Quadro T2000 (the bane of my existence with Ubuntu)
16GB RAM
512GB NVMe SSD (I changed the BIOS to AHCI to accommodate this, in case that's important)

5
  • Try completely uninstalling nvidia drivers here and then installing them again see the link. May 16, 2020 at 17:13
  • I hadn't had the repository at first (I had to add it). But I'll try this anyway.
    – Matt F.
    May 16, 2020 at 20:31
  • Okay, I've tried this. One thing that's probably important is that the only driver that went away after I removed the repository was 340. 435 and 440 were still there. And after I reinstalled the drivers with sudo ubuntu-drivers autoinstall, I had the same problem with the flashing white cursors.
    – Matt F.
    May 16, 2020 at 20:39
  • According to 20.04 releaes notes (wiki.ubuntu.com/FocalFossa/ReleaseNotes) there were some issues with Nvidia hardware, in particular with Quadro cards, this bug - bugs.launchpad.net/ubuntu/+source/linux/+bug/1822026 is for another card but it could be reñated May 16, 2020 at 21:15
  • The comments near the end sure sound like my situation. Isn't 20.04 an LTS release though? How could there be an error of this magnitude allowed to slip through?
    – Matt F.
    May 16, 2020 at 22:45

1 Answer 1

2

Just upgraded Ubuntu 20.04 and now have the same issue. I guess there's an issue with the newer kernel, because I did a dist-upgrade. The only way this works is if I blacklist nvidia. I've tried the bleeding edge Linux kernel and the latest nVidia driver direct from their site, compiled on my system.

Recommendation: if you use Linux, avoid any laptop with nvidia graphics (eg: Thinkpad P1 gen 2). My experience with the ThinkPad has been terrible: switching between intel and nvidia requires a reboot or at the very least, restart of X. Battery life is atrocious with the nvidia turned on. External monitors don't work with nvidia turned off. Several annoying issues after upgrades. Now this crap with the hang on boot. This is not fit for purpose as a 'daily driver' Linux laptop.

The only way I can get this laptop to work right now is with nvidia blacklisted, and of course that means I can't use the external monitor (because the intel chip isn't wired to the HDMI/DP ports).

My next steps: I'm going to backtrack kernel releases until I get this working again. An upgrade killed it, a downgrade should fix it.

3
  • I'm not having quite so many issues (I'm able to use the laptop without NVIDIA and I don't have any problems); it's more about trying to utilize what I paid for. Thanks for this information anyway.
    – Matt F.
    Jun 26, 2020 at 17:52
  • 1
    I can also use it without NVIDIA, but the external monitor is absolutely critical to me. After downgrading to an older kernel (5.4.0-26) I still have the issue, with nvidia drivers from Ubuntu (installed via "Additional Drivers") and also with the ones downloaded directly from NVIDIA's website. For now, I'm using an old MacBook because, ironically, it works better with Linux than a ThinkPad. Jun 27, 2020 at 9:30
  • For me, I am using the latest proprietary nvidia driver and secure boot disabled, and it hangs on boot about 2/3 of the time. No idea why it works sometimes randomly, but thankfully it does. So, if it hangs on boot for you once, try it again with a few times and move the cursor around, because it doesn't happen every time for me. Precision 5550, Ubuntu 20.04
    – Bart
    Feb 22 at 2:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.