0

I have a dual-boot setup, with Linux Mint 19.3 and Windows 10 each installed on a separate disk. Windows says that it is installed in a "Legacy/BIOS mode", and so I used this mode to install Linux as well. The installer detected the Win bootloader correctly, but after the installation there was no Windows entry in GRUB and no method of fixing this I found online has worked for me. I can boot into Win by using the BIOS menu, Win works fine, and so does Linux.

Here's my boot repair summary: http://paste.ubuntu.com/p/PV79583Jtc . And either I am not using boot-repair correctly or it doesn't help in my case, I've tried numerous combinations of settings and none worked.

I assume that there is something that I'm missing/have configured wrong, but I'd like to find out what that is, instead of just bruteforcing a system-reinstall...

Thank you for your answers

0

Try running sudo update-grub. That works on Ubuntu. Although, I don't know anything about EFI, so that might also be your issue.

| improve this answer | |
  • Did that already, didn't work I'm afraid – nisnan May 16 at 15:35
  • I'm out of my knowledge zone here, but I heard that UEFI machines have a directory for boot information. The UEFI is a newer replacement for BIOS, but that's about all I know. Try searching for EFI. Maybe that will shed some light. Also try Unix & Linux, since Mint is off topic on askUbuntu, I think. unix.stackexchange.com – user573739 May 16 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.