0

I have ubuntu 18.04, the default package for linphone version is 3.6, but i need to install a newer version which is linphone 3.12 which found on ubuntu 20.04 packages, although i don't need to upgrade whole os to ubuntu 20.04 but need to keep current release 18.04

I have read about apt pinning on the following article: https://medium.com/@george.shuklin/how-to-install-packages-from-a-newer-distribution-without-installing-unwanted-6584fa93208f and tried to add a file on preferences folder /etc/apt/preferences.d/linphone.pref as following:

Package: *
Pin: release n=bionic
Pin-Priority: 800


Package: linphone
Pin: release n=focal
Pin-Priority: 600

Package: linphone-common
Pin: release n=focal
Pin-Priority: 600

Package: linphone-dbg
Pin: release n=focal
Pin-Priority: 600

Package: linphone-nogtk
Pin: release n=focal
Pin-Priority: 600

also i did add all 20.04 repo to the file /etc/apt/sources.list

after i did update and tried to install linphone, the result was linphone 3.6 thats for ubuntu 18.04 repo and not 3.12

would u help please solve this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.