Package packettracer is referring to Cisco Packet Tracer 7.3. My OS is Ubuntu 20.04.
I installed packettracer, but the package requires a qt-at-spi package that I could not find in the Ubuntu 20.04 repository.
$sudo dpkg -i PacketTracer_730_amd64.deb Selecting previously unselected package packettracer. (Reading database ... 199702 files and directories currently installed.) Preparing to unpack .../PacketTracer_730_amd64.deb ... Unpacking packettracer (7.3.0) ... dpkg: dependency problems prevent configuration of packettracer: packettracer depends on qt-at-spi; however: Package qt-at-spi is not installed. dpkg: error processing package packettracer (--install): dependency problems - leaving unconfigured Processing triggers for gnome-menus (3.36.0-1ubuntu1) ... Processing triggers for desktop-file-utils (0.24-1ubuntu2) ... Processing triggers for mime-support (3.64ubuntu1) ... Processing triggers for shared-mime-info (1.15-1) ... Errors were encountered while processing: packettracer
I searched for that package, but what I found is only qt-at-spi for ubuntu 18.04. I tried to install it, but it also requires other packages.
$ sudo dpkg -i qt-at-spi_0.4.0-8_amd64.deb Selecting previously unselected package qt-at-spi:amd64. (Reading database ... 202991 files and directories currently installed.) Preparing to unpack .../qt-at-spi_0.4.0-8_amd64.deb ... Unpacking qt-at-spi:amd64 (0.4.0-8) ... dpkg: dependency problems prevent configuration of qt-at-spi:amd64: qt-at-spi:amd64 depends on libqt4-dbus (>= 4:4.8.0); however: Package libqt4-dbus is not installed. qt-at-spi:amd64 depends on libqtcore4 (>= 4:4.8~); however: Package libqtcore4:amd64 is not installed. qt-at-spi:amd64 depends on libqtgui4 (>= 4:4.8~); however: Package libqtgui4 is not installed. dpkg: error processing package qt-at-spi:amd64 (--install): dependency problems - leaving unconfigured Errors were encountered while processing: qt-at-spi:amd64
I searched again for those other packages (libqt4-dbus, libqtcore4, libqtgui4), but what I found is only for Ubuntu versions below 20.04 (i.e 18.04, 19.04, 19.10), there are none for Ubuntu 20.04.
I keep trying to install those packages, but they depend on other unavailable packages again, and so on.
I have tried to install Qt-5. Qt-5.12.8 installed but I still did not get the qt-at-spi package.
Packettracer doesn't even seem to need qt-at-spi, as it runs properly without error. However, when I tried to install another package (whatever is it), there is a dependency error:
packettracer : Depends: qt-at-spi but it is not installable E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
So, I must run "apt --fix-broken install" first and uninstall packettracer before I can install another package. Then when that another package installed, I reinstall the packettracer again. It is annoying.
$ sudo apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages will be REMOVED: packettracer 0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded. 1 not fully installed or removed. After this operation, 0 B of additional disk space will be used.
The question is:
- Can you help to find qt-at-spi for ubuntu 20.04? or
- Can I exclude packettracer from apt --fix-broken install?