Package packettracer is referring to Cisco Packet Tracer 7.3. My OS is Ubuntu 20.04.

I installed packettracer, but the package requires a qt-at-spi package that I could not find in the Ubuntu 20.04 repository.

$sudo dpkg -i PacketTracer_730_amd64.deb
Selecting previously unselected package packettracer.
(Reading database ... 199702 files and directories currently installed.)
Preparing to unpack .../PacketTracer_730_amd64.deb ...
Unpacking packettracer (7.3.0) ...
dpkg: dependency problems prevent configuration of packettracer:
 packettracer depends on qt-at-spi; however:
  Package qt-at-spi is not installed.
dpkg: error processing package packettracer (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:

I searched for that package, but what I found is only qt-at-spi for ubuntu 18.04. I tried to install it, but it also requires other packages.

$ sudo dpkg -i qt-at-spi_0.4.0-8_amd64.deb 
Selecting previously unselected package qt-at-spi:amd64.
(Reading database ... 202991 files and directories currently installed.)
Preparing to unpack .../qt-at-spi_0.4.0-8_amd64.deb ...
Unpacking qt-at-spi:amd64 (0.4.0-8) ...
dpkg: dependency problems prevent configuration of qt-at-spi:amd64:
 qt-at-spi:amd64 depends on libqt4-dbus (>= 4:4.8.0); however:
  Package libqt4-dbus is not installed.
 qt-at-spi:amd64 depends on libqtcore4 (>= 4:4.8~); however:
  Package libqtcore4:amd64 is not installed.
 qt-at-spi:amd64 depends on libqtgui4 (>= 4:4.8~); however:
  Package libqtgui4 is not installed.

dpkg: error processing package qt-at-spi:amd64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

I searched again for those other packages (libqt4-dbus, libqtcore4, libqtgui4), but what I found is only for Ubuntu versions below 20.04 (i.e 18.04, 19.04, 19.10), there are none for Ubuntu 20.04.

I keep trying to install those packages, but they depend on other unavailable packages again, and so on.

I have tried to install Qt-5. Qt-5.12.8 installed but I still did not get the qt-at-spi package.

Packettracer doesn't even seem to need qt-at-spi, as it runs properly without error. However, when I tried to install another package (whatever is it), there is a dependency error:

packettracer : Depends: qt-at-spi but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So, I must run "apt --fix-broken install" first and uninstall packettracer before I can install another package. Then when that another package installed, I reinstall the packettracer again. It is annoying.

$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.

The question is:

  • Can you help to find qt-at-spi for ubuntu 20.04? or
  • Can I exclude packettracer from apt --fix-broken install?
  • Qt4 is EOL & unsupported upstream (2015 upstream though Debian & Ubuntu supported it until 15-Mar-2019) which is why it started to be removed entirely in 2019 in the eoan & focal cycles (refer discourse.ubuntu.com/t/…). The app if maintained should have been ported to Qt5 (introduced 19-Dec-2012) Cisco need to re-package their tool for a supported Qt5 – guiverc May 16 at 0:15
  • Thanks @guiverc , I have installed Qt-5.12.8 but why still did not get qt-at-spi package? – xdnroot May 16 at 0:22
  • 2
    qt-at-spi was a Qt4 package with requirements for depreciated qt4 packages. That package doesn't exist in the Qt5 world. It's README starts "This is a Qt 4 plugin that bridges Qt's accessibility API to AT-SPI2." salsa.debian.org/a11y-team/qt-at-spi/-/blob/master/README As stated it should be re-packaged by Cisco (ie. raise a bug with them to do it & wait), or an empty package created in a PPA that does nothing for focal but meets the dependency requirement.. Just my thoughts/2c – guiverc May 16 at 0:41
  • 1
    Does this answer your question? Unable to install Cisco Packet Tracer 7.3 on Ubuntu 20.04 – guiverc May 18 at 6:07

Follow these steps :

cd Desktop
mkdir working-dir
cd working-dir
cp ~/Downloads/PacketTracer_730_amd64.deb .
wget http://ftp.br.debian.org/debian/pool/main/d/double-conversion/libdouble-conversion1_3.1.0-3_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/libj/libjpeg-turbo/libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/libj/libjpeg8-empty/libjpeg8_8c-2ubuntu8_amd64.deb
ls -l
chmod +x *
ls -l
sudo dpkg -i *
sudo featherpad /var/lib/dpkg/status #featherpad here, is my text editor
    #ctrl+f (search) > Depends: libdouble-conversion1, qt-at-spi > (delete-this-line) > save & close
sudo apt --fix-broken install

I also put a video on YouTube https://www.youtube.com/watch?v=5FuBKG49bIY it shows the same process but could be more helpful.

| improve this answer | |
  • 2
    I would recommend you clean up your instructions, most of that is not necessary. All you need is one mkdir/cd to have an empty work directory if you want, then one wget to download the .deb files, and dpkg to install them (no need for chmod). After that, you shouldn't use featherpad or other GUI editors with sudo in general, something like nano or vim would be more appropriate. Running GUI applications as root can cause problems. Also better not delete the whole Depends: entry, but only remove the qt-at-spi entry from it, leave the other dependency relations intact! – Byte Commander Jun 4 at 11:13
  • Thank you, it's works. – xdnroot Jun 5 at 16:32
  • You're welcome :D – Yacyn CHERRADI Jun 10 at 19:48
  • Thank you Byte Commander :D – Yacyn CHERRADI Jun 10 at 19:48
  • This didn't fix my problem, unfortunately. – sam islam Jul 7 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.