136

I'm playing with ubuntu 12.04, precise pangolin, and there's an issue I can't see how to solve.

If I have three instances of, let's say, Firefox, in the switcher appears a single Firefox icon, I have to wait something like a second for it to open so that I can finally choose the one I'm looking for

I tried with compiz-settings and the unity plugin but couldn't find an option to ungroup Windows.

  • 1
    aking1012, riateche, thanks a lot for your answers, I as already aware of that, I'm just trying to avoid the hover or the alt-down stuff and just get back to thre previous behaviour – opensas Apr 21 '12 at 19:39
  • not a problem, i just don't think it's going to happen. it's a feature not a bug – RobotHumans Apr 21 '12 at 21:03
  • 4
    if you want to work between two open firefox, for example, it's kind of annoying, can't it be configured? – opensas Apr 21 '12 at 22:52
  • 1
    your other question is another way of asking this one, if you're working with multiple desktops(like I am) and you have multiple windows for an application open(like I do) then alt-tab immediately opens the most recently focused window for a given application. it's starting to sound like complaining – RobotHumans Apr 22 '12 at 1:14
  • 1
    See also How to get previous behaviour of alt-tab task switcher in 11.10 - seems like this is a a dup. – nealmcb Apr 30 '12 at 16:10

12 Answers 12

189

You can also press alt + ` (the key above Tab) to switch between instances of the current application.

| improve this answer | |
  • 12
    I like this because I can do it with one hand. – Jay Bazuzi May 1 '12 at 5:38
  • 14
  • 5
    yes, this works but it doesn't ungroup. an ungrouped switcher recognises that just because a file is in the same application doesn't mean that it relates to the same task eg task 1 = (PDF1, Writer doc 1), task 2 = (PDF2, gedit, Writer doc 2). The application grouping just gets in the way of this. – jdpipe Jul 25 '16 at 1:01
  • 1
    This is the next best thing I've found without downloading any other packages. – Kenmore Mar 14 '17 at 21:57
  • 2
    I'm surprised that no one has mentioned Alt+Esc when that actually cycles through all windows while this one just cycles in that same group of windows. – shriek Mar 9 '19 at 20:31
57

Open Settings > Keyboard > Navigation > Switch Windows > Your_Key-Combo > Done! I am using Ubuntu 17.10. Its that simple

| improve this answer | |
  • 15
    Tested with 18.04, I replaced the Alt + Tab... it works! – 4ndt3s Jul 25 '18 at 9:33
  • 4
    This is the best solution for a permanent, single key combo solution, which may or may not be what the OP wanted. Note that if you do decide to go back to the default method of application switching, simply disable the "Switch Windows" key combo, then the "Switch Application" key combo will be reactivated. – iND Sep 12 '18 at 12:40
  • This also works in the GNOME window manager in Ubuntu 18.04. If you're looking for the Windows style alt-tab, this is it. – Arye Eidelman Sep 24 '19 at 23:45
  • There is no "Switch Windows" in the Navigation group, and I'm in 18.04 too, but using Unity. Any workarounds? – MestreLion Sep 20 at 6:30
26

Press down arrow while holding alt+tab to view list of windows for current application.

| improve this answer | |
  • 11
    That works but it's pretty cumbersome. I've never had this annoying task switching problem in Windows. – Dan Dascalescu Jun 25 '16 at 21:13
  • 1
    You can also just Alt-Tab to the one with multiple and wait for 3 seconds and it will ungroup them and then you can Alt-Tab through them. Neither of these are ideal solutions, though. – Kenmore Mar 14 '17 at 21:55
21

To get all windows expanded from the beginning in a single list while switching with ALT-TAB I've gone to CompizConfig -> Windows Management -> Static Application Switcher (enabled this): Dialog popped up, I selected to solve the conflicts, in any of the question pop ups I've hit the most rightest button to deactivate the conflicting button. Thats all.

(To get back to Unity behaviour, goto CompizConfig -> Desktop -> Unity Plugin -> Switcher (tab) -> reset all settings with the x buttons at the right)

EDIT: You have to have the compiz-plugins package installed in order to access the Static Application Switcher plugin.

| improve this answer | |
20

This question is a bit old, but Unity has still the same problem. The solution is hidden in the Compiz Plugins:

sudo apt-get install compizconfig-settings-manager compiz-plugins

Start ccsm (the Compiz Config Settings Manager) and find

  • Desktop ► Ubuntu Unity Plugin ► Switcher (tab)

Disable the key combinations for next and previous windows Alt+Tab and Shift+Alt+Tab, by editing the key and deleting its contents.

Next, pick a different application switcher. Best for the purpose seems to be the "Static Application Switcher". You can find it by going back and performing a search (with the Filter).

Enable its key combinations for next and previous windows by clicking on Disabled. Then you will be asked and you can input Alt+Tab and Shift+Alt+Tab.

Close sscm and now you have one icon for each open window in the application switcher, no annoying grouping anymore.

| improve this answer | |
  • How is this answer conceptually different from Hartmut's? – Dan Dascalescu Jun 25 '16 at 21:20
  • 1
    This is the better answer, as it says that next/prev windows have different combos and therefore need to be changed. – Albus Dumbledore Jan 18 '17 at 22:05
  • Just a note: I assumed ccsm had to be run as root, but this is in fact NOT the case. Run ccsm as your regular user account. – Alex Jan 27 '17 at 17:22
8

As of Ubuntu 16, you can also press Start + W, which will bring this: enter image description here It's faster than alt+tab task switcher and doesn't group windows.

| improve this answer | |
  • Sadly this doesn't seem to work now, perhaps since the removal of Unity. – mwfearnley Jun 17 at 12:07
  • Haven't tried it in a while, but the Ubuntu maintainers can't make up their minds on one UI - they keep changing it. I don't know where they are now, but I heard they dropped Unity (thankfully). So YMMV. – maaw Jun 17 at 17:20
  • @mwfearnley: you can still install Unity in Ubuntu 18.04+ – MestreLion Sep 20 at 6:27
4

If using Gnome Desktop, you can use extension name: Alternatetab enter image description here

| improve this answer | |
2

I find Alt+Esc useful in such cases. (Ubuntu 18.04.)

| improve this answer | |
0

Just hover during alt-tab. It will expand the group windows with previews of each window.

I was informed for one of my questions that "feature requests" are "wishlist bugs". This is how I responded.

| improve this answer | |
  • 1
    thanks for the tip, but in this question I found that for feature request / wishlist bug, there was this site brainstorm.ubuntu.com, I've just registred and I'm waiting for the email... – opensas Apr 28 '12 at 15:43
0

I found a simple and beautiful solution that works on Ubuntu 17.10 (Artful Aardvark). Follow this tutorial and alt-tab will switch between all windows (no app grouping). It also changes the visual appearance of the switcher. Now all you open windows will display in a 3d carousel.

The tutorial basically makes you install the GNOME Shell Extension on your browser and from there an you can install apps that will manage alt-tabbing. The one I choose is: coverflow-alt-tab

| improve this answer | |
0

For people looking at a modern solution.

I was looking for another problem, and found an extension that fixes the grouping window problem as well. Works on 18.04 LTS

Install 'Dash to Panel', as instructed here

  1. Launch 'Ubuntu Software' which is built in Ubuntu 18.04.
  2. Install 'Dash to Panel' shell extension from 'Add-ons' -> 'Shell Extensions'. Scroll down to find the 'Dash to Panel' extension and install it.
  3. Press 'Extension Settings', find the settings button of the 'Dash to Panel' in the menu.
  4. Open the configuration settings of 'Dash to Panel' and find the 'Position and Style' tab. On this tab you would find the 'Clock Location' configuration. Change this to 'Right of status menu'.
| improve this answer | |
  • Ubuntu 18.04 does not use the Unity desktop, which is the topic of the question. – Kurankat Sep 14 at 2:22
0

With isolate workspace from dconf editor, as discussed here, now I can ungroup windows of same app!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.