10

I have a Thinkpad X380 Yoga running Ubuntu 20.04 freshly installed (I am a complete beginner coming from windows).

I have tried the solution suggested here:

[How do I install a fingerprint reader on Lenovo ThinkPad?

But when I type:

sudo add-apt-repository ppa:fingerprint/fingerprint-gui

Then I get:

Packages for Fingerprint GUI (http://www.ullrich-online.cc/fingerprint/)

NOTE: Fingerprint GUI is no longer maintained and is not compatible with Ubuntu 20.04 and newer

Supported readers (run command lsusb to find out the ID of your reader)
============
https://fprint.freedesktop.org/supported-devices.html
and
     0483:2015    147e:1003    147e:3000
     0483:2016    147e:2015    147e:3001
     147e:1000    147e:2016    147e:5002
     147e:1001    147e:2020    147e:5003
     147e:1002

However, the ID of my reader doesn't seem to be in the list :

joe@joe-ThinkPad-X380-Yoga:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 138a:009d Validity Sensors, Inc. 
Bus 001 Device 003: ID 13d3:584b IMC Networks Integrated Camera
Bus 001 Device 002: ID 8087:0a2b Intel Corp. 
Bus 001 Device 005: ID 056a:5150 Wacom Co., Ltd Pen and multitouch sensor
Bus 001 Device 007: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm not even sure the fingerprint reader is there, I'm assuming it's "Device 004", but I'm not even sure.

Can someone help me out?

Thanks in advance :)

1 Answer 1

4

Fingerprint - GUI says that it is not compatible with 20.04 and as such if you see that a package is unmaintained you should quit using it especially for stuff like security.

You could try out this method. Use the second one with default apps:

This method will not work for all the devices. Ubuntu does not support major types of Fingerprint scanners available on the market. This is the best alternative and official way to enable the Fingerprint login on your Ubuntu systems.

  • Open the “Settings” option
  • Go to the “Users” option
  • Press on Disabled option, next to Fingerprint Login to add a fingerprint for the selected account.
  • Follow the instructions provided in the manual
  • Slowly move your finger in 360° over the Fingerprint scanner
  • The dialog will say “Done” message once it got completed

This is also something you could try out.

Edit: Since the first link is dead, here is the version from archive.org

8
  • Did it work? If there is any further problems please post the details. If it worked please accept the answer so all may benefit
    – A.Sha
    May 30, 2020 at 5:17
  • I could make it work. But before clicking on "disabled" you have to choose "unlock" at the top of the window. And after pressing "Disabled" you have to press "+" in the new window, before scanning any finger.
    – Henrik R.
    Sep 8, 2020 at 14:03
  • 2
    Sorry but there is no such thing as "disabled" on my user pannel, but I found the solution: github.com/uunicorn/python-validity Jan 17, 2021 at 4:29
  • 1
    NICE, thank you very much! Simply activating the fingerprint reader via Settings->Users etc. worked for me with ubuntu 20.04 on a lenovo X1C7.
    – Stefan
    Apr 8, 2021 at 11:57
  • @user1172258 Thanks for your solution. It works for my T470
    – sondt87
    Sep 30, 2021 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .