8

I have used VMWare Workstation 15.5 running on Windows 10 Pro to create a VM for Ubuntu 20.04. I cannot access the shared folder in Ubuntu.

What I have done so far:

  1. Created a shared folder called "Share" in the Windows 10 Host
  2. Given read/write permission to Everyone
  3. Added the Share folder in VMware VM Settings page and chose Always Enabled

When I turn my Ubunut 20.04 VM on, I cannot see the Share folder. vmware-hgfsclient shows that there is a folder called Share. However, cd /mnt is empty.

How can I get Ubuntu 20.04 to mount the Share folder and then access it?

I am a newbie so please be gentle.

Thanking eveyone in advance for any assistance provided.

sujayv_au

5 Answers 5

13

This answer is similar to the one posted by @user1099476 but will apply at boot.

Edit /etc/fstab and add:

vmhgfs-fuse    /mnt/hgfs    fuse    defaults,allow_other    0    0

Make sure the target folder exists. If not:

sudo mkdir /mnt/hgfs

Then remount:

sudo mount -a
10

I had the same problem, and still don't have permanent solution. All I have is temporary fix as follows.

After every Guest (Ubuntu) powers up, go to terminal, and type:

sudo vmhgfs-fuse .host:/ /mnt/hgfs/ -o allow_other -o uid=1000

You should see your shared folders under /mnt/hgfs.

(If anyone has better solution, please let us know.)

0

For me, I'm using virtualbox 6.1, which has a insert guest additions cd image in devices on menu bar, then it works. therefore, Vmware should have some sort of this additions.

VMware Tools

2
  • Thank you for the infromation. I can confirm that the vmware tools have been installed. As a newbie, I don't know how to add the vmware-tools to the CD but will be willing to try if someone can give me some pointers on how to do it.
    – sujayv_au
    May 15, 2020 at 3:41
  • No, there is no need to add the vmware-tools to the CD, It is just needed to install to your guest ubuntu on vmware. I find some links about this. kb.vmware.com/s/article/1022525 pubs.vmware.com/workstation-11/…
    – Kanaza
    May 15, 2020 at 3:50
0

This worked for me:

Edit /etc/fstab and add:

vmhgfs-fuse    /mnt/hgfs    fuse    defaults,allow_other    0    0

use sudo gedit command to edit fstab file

Make sure the target folder exists. If not:

sudo mkdir /mnt/hgfs

Then remount:

sudo mount -a   
0

this tip is also working for UBUNTU 2204 LTS as Guest.

My Host conf is : windows 10 Pro with VMware Workstation Player 16.2.3 (latest). My Guest conf is : Ubuntu 2204 LTS Desktop with standard install (so using open-vm-tools-deskop package included, I didn't install the VMware tools proposed by VMware Workstation Player).

When I turn my Ubuntu 22.04 VM on, I cannot see the Host shared folder named "_Shared". And command vmware-hgfsclient shows that there is a folder named "_Shared". However, /mnt/hgfs was empty.

By updating /etc/fstab with the line above then rebooting the Guest, now I am able to see the folder "_Shared". Then I am able to move files from Guest to Host and Host to Guest (attribute "Enabled" set on Host side for this folder).

Note that enabled this folder share allows now the copy/paste (by right clicking) from Guest to Host, to any target folder on Host (before this setting, the copy/paste was only working from Host to Guest). I used it to easily copy/paste small files (didn't know the max size allowed)

Hope it will help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.