I tried to add the resolution with xrandr and then setting it but it gives the no gamma recognized error.

I tried with 12.04 beta and 11.10 with no results. Also it seems that there's not much info about this model.


The x101ch uses a new graphics driver, the GMA3600. Kernel drivers for the GMA3600 are still experimental and have not made it into the kernels that are in Ubuntu's repositories yet. Because your kernel doesn't have the drivers it falls back to using the default resolution, 800x600.

You've got two options:

1) Wait for the GMA3600 drivers to make it into mainline, easy enough...

2) Compile the kernel with the experimental drivers. This isn't as hard as it sounds, especially since someone has already done it. The kernel produced through that guide works fine with the x101ch, has wireless drivers and everything. If you've not compiled a kernel before you may need to go install some packages.

Let me know if you have problems following the guide...

| improve this answer | |

What commands did you try? xrandr --output LVDS1 --mode 1366x768 != to xrandr -s 1366x768 for example.

Be good to see the output of your xrandr -q.

| improve this answer | |
  • xrandr -q xrandr: Failed to get size of gamma for output default Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600 default connected 800x600+0+0 0mm x 0mm 800x600 0.0* triedn adding the mode "1024x600_60.00" 49.00 1024 1072 1168 1312 600 603 613 624 -hsync +vsync but when doing xrandr -output default 1024x600_60.00 it gave the "Failed to get size of gamma for output default" and did nothing. – Nodens Apr 21 '12 at 12:53
  • formatting is a bit screwed. pastebin? – hendry Apr 22 '12 at 2:25
  • No problem link – Nodens Apr 23 '12 at 6:46
  • 1
    What is your video card? lspci | grep VGA. Is it's Intel following this tutorial looks like your best way forward: intellinuxgraphics.org/how_to_report_bug.html – hendry Apr 24 '12 at 4:16
  • 1
    00:02.0 VGA compatible controller: Intel Corporation Cedarview Integrated Graphics Controller (rev 09) I will try that tutorial. thx. – Nodens Apr 25 '12 at 6:36

we have a Casper netbook (some Taiwan product) with intel chipset. When I installed Xubuntu it only worked at 800x600 and I couldn't find any drivers that support 1024x600. I was about to give up and look for another OS but then a miracle happened. We connected our LCD TV and rebooted while it was on and VGA cable was plugged. Suddenly netbook display was recognized as 1024x600 and still it works at that resolution even without VGA cable. I don't really know why but it works now. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.