1

I run Ubuntu 18.04 on a Hewlett-Packard Pavilion dv6-3050us Entertainment Notebook. For nearly 2 years this has worked fine but suddenly I can get no internet. My hardware switch, which used to toggle between internet on or off, now toggles between airplane mode and nothing.

If I click on activities and Wi-Fi I get a message no Wi-Fi adapter found. iwconfig returns lo no wireless extensions. lspci -nnk does not include a network controller in its output list. sudo lshw -C network returns blank.

I would be grateful for advice, and for any comments on what may have caused this.

Update 15 May - thank you for your contributions, K7AAY and Czar

ubuntu-drivers devices returns nothing.

I have followed (1) of the link you posted, Czar, but disconnecring the battery and holding the power button down has no effect.

(4) of that link - the HP website tells me that it does not provide drivers for my machine for any OS apart from Windows.

(6) of that link - I do not know how to reseat a wireless card.

You asked whether I had installed Ubuntu 20.04. I haven't, but might that solve the problem?

I'm not sure what you mean by changing the kernel from my grub menu. If I restart in recovery mode, or using Linux 4.15.0-96-generic, the problem persists.

I could buy a USB wifi adapter, but are there other things I could try first please?

1
  • There are multiple dv6 machines. What is the model part number from the serial number sticker? Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit – K7AAY May 14 '20 at 16:27
0

My guess is a bad pcie wifi module. Lets get some info and here are some things to try:

Did you upgrade to Ubuntu 20.04? Try ubuntu-drivers devices and if you have a driver available then install with sudo apt-get install *xxxxdriverxxxx*

Does the problem exist if you change the kernel from you grub menu during boot?

Try steps 1, 4 (bios update) and 6 from https://h30434.www3.hp.com/t5/Notebook-Wireless-and-Networking/HP-pavilion-dv6-1390ev-wireless-not-working/td-p/1843501

Create a Live-USB of Ubuntu and check if it works? If it doesn't then it's probably hardware issue not software. https://ubuntu.com/tutorials/try-ubuntu-before-you-install#1-getting-started https://ubuntu.com/tutorials/try-ubuntu-before-you-install#1-getting-started

Purchase USB WiFi adapter as a replacement. I own several $5 ones that I use for troubleshooting. I've only had issues with AC speed USB adapters on Linux. Difficulties with compiling drivers with limited manufacturer linux support. Most time the cheap stuff works on Linux just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.