40

I am a Gnome user. Just out of curiosity, I installed the package kubuntu-desktop to check out the latest KDE. The package has hijacked and replaced the nice ubuntu boot splash with the blue KDE one. How can I get the original boot splash back ? Which package should I re-install ?

36

If you want to quickly change it back, sudo update-alternatives --config default.plymouth will give you a list of screens you can choose from.

| improve this answer | |
  • 2
    Thanks, that worked for me. I installed the gnome desktop, but ended up not liking it. When I uninstalled it, it left the gnome foot logo on the boot and shutdown screens. This got me back the good old ubuntu logo. :) – The Unknown Dev May 6 '16 at 0:17
  • This worked temporarily for me. On the next boot kubuntu spalsh screen was back. Maybe it has something to do with the fact that kubuntu splash is in auto mode and the default is in manual mode. – ShuaibKunji Nov 2 at 7:22
10

Or simply

sudo apt-get remove plymouth-theme-kubuntu-logo

If you don't want drop KDE

| improve this answer | |
5

If you do this, you should be back to normal:

sudo apt-get purge kubuntu-desktop
sudo apt-get autoremove --purge
sudo apt-get install ubuntu-deskop

The splash screen is selected via update-alternatives, but the above should restore the links too.

| improve this answer | |
4

Trying out codeMonk's answer gave me an error after I selected the ubuntu-logo option:

update-alternatives: warning: forcing reinstallation of alternative /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth because link group default.plymouth is broken.

Running this command fixed that for me:

sudo apt-get install --reinstall plymouth-theme-ubuntu-logo
| improve this answer | |
-1

Turning ON/OFF the splash screen on boot is easily changeable via GRUB.

sudo vim /etc/default/grub

You'll see GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  1. Remove splash from this line
  2. Save with :wq
  3. sudo update-grub
  4. sudo reboot now

Splash screen will no longer appear.

| improve this answer | |
  • While editing system files, sudoedit file is the preferred way. It chooses vim if available, else falls back to nano – Mahesh Nov 10 '12 at 4:40
  • 1
    I believe it simply defaults to the editor specified by the EDITOR environment variable echo $EDITOR, which on some systems is vim (or vim.tiny) on others it is nano. You can test this by running EDITOR=nano sudoedit /etc/default/grub or EDITOR=vim sudoedit /etc/default/grub it chooses the one you specify without making it permanent. – dragon788 Sep 6 '17 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.