I have a Digitus DN7045 wireless USB dongle which uses the Realtek RTL8188CUS chipset. If I disable security on my wireless network, it works fine. As soon as I enable any type of security, it stops working and Network Manager keeps asking for my network key/password over and over again.

The same dongle works fine on Windows with or without security and I've already updated to the latest driver (8192cu) from Realtek.com.tw and I've already blacklisted the default driver, rtl8192cu.

None of this has helped but, like I said, it is working, just not with security enabled. What can I try next?


I had the same problem and here's how I solved it. The summary is the built-in driver didn't work work completely, and I downloaded installed the manufacturer's driver instead, making sure the new driver was set to start on boot while the built-in driver was blacklisted.

  1. Search on the Realtek site for your hardware. For me, I used lshw -c network to see that I had RTL8192cu, so I searched for that, which led me here

  2. You should get a zip file to download it. I used a second computer for this and saved it to a USB drive, and then transferred it over the SneakerNet to the troubled computer.

  3. After unpacking the 'zip' file, enter the directory it creates in the terminal and run sudo bash install.sh

  4. Disable the built-in driver by editing /etc/modprobe.d/blacklist.conf and adding a line like blacklist rtl8192cu (The name you use should match output from lshw -c network

  5. Set the new driver to be loaded by boot by editing /etc/modules and adding the line 8192cu

  6. This step is optional. You can immediately test the new driver by manually unloading the old driver and manually loading the new driver. After these steps, the networking should work.

    sudo modprobe -r rtl8192cu sudo modprobe 8192cu

  7. Reboot and test the networking again to confirm that your changes 'stick'.

I recommend keeping the "zip" file from Realtek around in case you need it again. The changes to files in /etc should survive upgrades, but the driver itself may not survive all kernel upgrades and the "install" step may need to be repeated.

  • Excellent answer, got my NWU271 from addon working thanks to this. +100 if I could! – BullBoyShoes Jul 23 '12 at 12:06
  • I do like you said. But when I plug my 8192cu usb wireless card, my computer screen is off. At that time I even can not use Alt SysRq k or Alt SysRq + reisub. I am using the latest driver of 8192cu on ubuntu 12.04. – waterloo2005 Dec 12 '12 at 4:03
  • In RealTek site, I download 8192cu drive which is for Linux Kernel 2.6.18~2.6.38 and Kernel 3.0.8. But now in Ubuntu12.04 my kernel is 3.2.0-34. Every time I plug the usb 8192cu wireless card my system halts. – waterloo2005 Dec 13 '12 at 11:23
  • 1
    Sadly it doesn't compile on my system. I get a warning about casting an integer to a pointer of a different size, and the warning is treated as an error. – Timmmm Aug 4 '13 at 15:52
  • @Timmmm, leave the details of your system here. What OS and version, and an exact copy paste of the error. – Mark Stosberg Aug 5 '13 at 12:40

Wow worked like a charm for last 1 hour. Just one thing. I struggled to edit the files mentioned. So if anyone want to edit the files mentioned see below:

In Ubuntu, you can edit roots files using sudo command in terminal emulater:

$sudo nano somefile

Substitute nano with your favourite text editor.


$sudo nano /etc/modprobe.d/blacklist.conf

just note nano is a bit primitive editor.


The Solwise NET-WL-UMD-606N mini wireless dongle uses this chip and has similar problems with recent Ubuntu versions. I have packaged up a procedure to replace the driver in a script and posted it on the Solwise forum here.

`lsusb` reports the Solwise device as 0bda:8176 and the procedure will probably work for the Sabrent Mini USB-A11N (which also shows as 0bda:8176) and Guillemot Corp Hercules HWNUp-150 802.11n Wireless N Pico (which uses the same Realtek RTL8188CUS chip). It MAY work for the Netgear Micro G54/N150 (0846:9041) and Bekin N150 (050d:945a).
  • Unfortunately the link is now dead.. – George Feb 19 '16 at 18:11

For my case, Ubuntu 13.04 with linux image 3.8.x, this deb package for rtl8188cus driver was the solution. Need install dkms previously.


I have several usb dongles with the 8188/8192cu chip. Some have an antenna and some not. What I find is that despite having the same chip, some of them will work in Ubuntu 12.10 and 13.04 right out of the box without having to re-install the driver and some won't work with the native kernel drivers. One of the8188/8192cu minis without an antenna will connect if I move the laptop closer to the AP and the other won't and that tells me distance can be the real problem in some cases rather than the driver. I find it very interesting that different dongles with the same chip may or may not work with the native drivers. I also have a Rosewill RNX-EasyN1 that has the Raylink 2800 chip that is instantly recognized by all the Linux distros I have tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.