0

I am unable to play videos in facebook or bbc iplayer. I am using firefox as my browser. In facebook,the video looks just the same after I press "play" as before. Its as though I have not pressed play at all. In bbc iplayer I get the message "this content doesn't seem to be working. Please try again later". I have tried several suggestions from this site including:

$ sudo apt-get install gnome-tweaks  
$ sudo apt-get install libdvdnav4 libdvdread4 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libdvd-pk  
$ sudo apt-get install ubuntu-restricted-extras

amongst others

Each time I get the following error message and have no idea what it means:

Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 4730 (apt-get)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

Please note, I am not an experienced linux user and my knowledge of coding and using the command terminal is very limited (the sudo commands I used above were copy pasted from similar problems posted on this website). I would therefore appreciate any explanations in clear, plain english, assuming no knowledge of coding or even how video enablement works in linux. Thank you

4
  • 1
    Hi C.Diamantis! You shouldn't even need to install those programs. Can you please edit your question and add what browser you're using to access Facebook and how exactly the videos don't play. Do you not see the video? Can you click on play? The more info, the better. – Béné May 14 '20 at 7:58
  • ubuntu-restricted-extras should be sufficient for FF. But that lock means that you porbably couldn't accept MS license, thought that installation froze and closed the terminal ;-) Maybe installation didn't finish and you can accept it now. It is hard to guess. – Pilot6 May 14 '20 at 9:57
  • Ok, Pilot6, assuming you're correct, is there a way of rectifying this? – C.Diamantis May 14 '20 at 10:03
  • Turns out your assumption about my non-acceptance of MS licencse was correct. I followed instructions given by Bene (can you see this at your end?) and it worked. Thank you for the suggestion, very much appreciated – C.Diamantis May 15 '20 at 10:42
0

For video playback in the browser you only need to install the package ubuntu-restricted-extras. To do so open a terminal and type:

sudo apt install ubuntu-restricted-extras

Should that still fail with the error message you posted above, reboot and try again. Should the error persist, a previous update might have been interrupted and left the lock file in place, as Pilot6 commented above. To fix that:

  1. In a fresh terminal type sudo rm /var/lib/dpkg/lock-frontend
  2. Then make sure, all packages are installed correctly with sudo apt-get -f install
  3. Make sure the codecs are installed correctly with sudo apt install ubuntu-restricted-extras. When you are prompted to accept the EULA for the Microsoft fonts package, use Tab and Enter to agree.

After restarting your browser, video playback should work.

2
  • 1
    It worked! Youre a star! Special thanks to Pilot6 as well. – C.Diamantis May 15 '20 at 10:40
  • My pleasure! Glad it worked. :) – Béné May 15 '20 at 19:32
0

I can now play videos thanks to the input of Bene and Pilot6. Solution was as follows: 1. $ sudo apt install ubuntu-restricted-extras On prompt/ message/ question by command terminal I typed in: 2. $ sudo dpkg --configure -a I accepted MS license by pressing tab, enter Package installed successfully

-1

I tried and failed to get videos to work. I install both clv and mpv and found that both worked. I chose to set music and video in Settings -> Default Applications to mpv. Whist I was fighting videos I may have install various codex which might just be essential to mpv.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.