I have hp laptop. Most of the time my wifi can't connect to any network after 2-3 hours after booting up(it shows unavailable and no wifi adapter found). This problem gets solved by several time rebooting system. Sometimes wifi gets connected but it has no internet access. so tried this method but it doesn't work(I am assuming because of updated kernel of 20.04).

My output of lspci -v | grep -i network

0d:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter

Output of lspci -knn | grep Net -A3; rfkill list

0d:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
Kernel driver in use: rtl8723be
Kernel modules: rtl8723be
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
5: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Output of dmesg | grep rtl after disabling fast startup in windows

[   13.082292] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723b_fw.bin
[   13.990240] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723b_config.bin
[   13.990267] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   15.016968] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
[   15.019349] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   15.020078] rtlwifi: rtlwifi: wireless switch is on
[   15.062183] rtl8723be 0000:0d:00.0 wlp13s0: renamed from wlan0

Output of grep iwl /etc/modprobe.d/*

/etc/modprobe.d/iwlwifi.conf:# /etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/iwlwifi.conf:# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
/etc/modprobe.d/iwlwifi.conf:# microcode file installed on the system.  When removing iwlwifi, first
/etc/modprobe.d/iwlwifi.conf:# remove the iwl?vm module and then iwlwifi.
/etc/modprobe.d/iwlwifi.conf:remove iwlwifi \
/etc/modprobe.d/iwlwifi.conf:(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \

2 Answers 2


My solution has been to use wired connection (through a USB/RJ-45 Hub and Ethernet cable) to have Internet access in order to download and install the WiFi Driver.

So, when you are connected :

  1. open Software and Updates
  2. go on the Additionnal drivers tab
  3. check Use DKMS source for the Realtek xxxx PCIe WiFi Driver...
  4. click Apply

If you didn't already enable the "Secure Boot" / MOK upon Ubuntu Install you will have to do it, so next steps will apply :

  1. It'll ask you to fill out a new password for this install.
  2. when you reboot the system, it'll open up MOK management.
  3. Click on Enroll MOK.
  4. You'll need to type the password for this install that you set in step '5' (If you don't do this step your install will be canceled.)
  5. It'll give your an option to Reboot the system.

Since Ubuntu 20.04, you need to enable Secure Boot during Ubuntu install to have access to theese kind of "proprietary" driver


My laptop: HP Probook 655 G2, Ubuntu 20.04.4 LTS.

I had an issue with the WLAN adapter too. Ubuntu started fine but very soon the WLAN icon disappeared and there was no WLAN device visible in the network settings. No internet connection. I noticed some log entry in syslog indicating some issue in loading the driver suggesting PCI problem. I ended up rebooting and entering BIOS. I disabled the integrated LAN controlled and after reboot WLAN works fine. So, I had to disable the LAN to get WLAN working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .