I've just installed Ubuntu 20.04 yasterday on my ASUS F512D (also known as X512DA), and everything is working fine, i was worried about the Ryzen 5 3500U and graphics not working, but everything just worked, the thing is my laptop has a Fingerprint Sensor (the ones where you DON'T swipe your finger) and was checking and Ubuntu 20.04 added fingerprint support, i set it up, with no problems, although Ubuntu is asking me to swipe my finger, and this fingerprint sensor doesn't work in that way, but even then it let's me set it up, the problem is i Log Out, and when Ubuntu asks me to again swipe my finger it doesn't seem to recognize it, nothing, not even a error or somenthing like that. I have tried to see if its a driver problem or something like that but i havent found anything yet. Help

(My fingerprint sensor is from ElanTech but i don't know how to see what model it is)

  • 1
    Not all sensors are supported by Linux. – Pilot6 May 14 '20 at 8:47

I had similar problem (ASUS UX 430U) with "DON'T swipe your finger" fingerprint reader. It turns out that you are suppose to swipe that finger after all (even though on Windows 10 you don't have to).

Proposed solution:

  1. Re enter your fingerprint via Settings -> Users -> Fingerprint login or via command fprintd-enroll.
  2. Verify successful change either by logging out (save your work prior) or by command fprintd-verify

In case it does not help there is possibility that your fingerprint driver is not supported. To verify this you should try this (original source):

  1. lsusb and find fingerprint reader (my is ID 04f3:0903 Elan Microelectronics Corp. ELAN:Fingerprint)
  2. check for supported devices
  3. if your device is not supported you can open issue on GitHub page

Good luck.

  • Thank you for trying to help, +1 for that. But, it turns out my fp sensor isnt supported :(. Thank you and sorry for the late reply! – me is me Jul 13 '20 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.