38

I upgraded to Ubuntu 20.04 today, choosing LightDM over gdm3 during the upgrade. During the upgrade I was asked if I wanted to keep or replace /etc/sane.d/dll.conf file. I decided for keeping it.

Now, without actively rebooting, the "Oh no! Something went wrong" screen appeared.

As I am still inexperienced with this kind of troubleshooting, I feel it wouldn't be safe to just try out answers from other threads that don't have exactly the same 'history'.

Solutions I read included Ctrl+Alt+F4 and trying to login and get more information from the command line (Oh no! Something has gone wrong on restart).

Is that safe to do? Ideally, I'd like to save my data that is stored on an encrypted harddrive before trying to fix errors. I'd like to avoid reinstalling the OS.

From reading other threads, I know this post may be criticised as not being precise enough or haven't tried enough, but really I cannot get more information from that white screen myself and don't want to risk ruining everything just to provide more information...

Thank you for your help!! :)

Edit: I have no idea if the problem is related to lvm2-activation-generator, as in Ubuntu 19.10 “Something has gone wrong” after update from 19.04 This and other solutions include booting from a live usb. Can I do this 'safely' by simply switching the laptop off at this stage? Do I have to do sth before?

2
  • 1
    Does this answer your question? Ubuntu 19.10 "Something has gone wrong" after update from 19.04
    – Jos
    Commented May 13, 2020 at 13:33
  • No worries. I just had to completely reinstall my desktop environment because a "solution" on another stack exchange question completely hosed it, and I had it overwrite all those .conf files with the stock ones, and it left me with that "something has gone message" too. It's not anything you did, it's just what Linux is like.
    – John Smith
    Commented Nov 10, 2023 at 4:00

14 Answers 14

57

This will go a long way toward making that "Oh no something went wrong!" sign go away. First, press Ctrl+Alt+F3 to trigger the CLI, and login. Execute the command:

sudo apt-get update && sudo apt-get dist-upgrade 

to continue upgrading. Your machine will install the missing resources, and finish upgrading, and then you just have to clean up and reboot:

sudo apt-get clean && sudo apt-get autoremove && sudo reboot

Best of luck!

2
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Mitch
    Commented May 14, 2020 at 7:18
  • This worked for me after following the recommendations from failed dist-upgrade to run: sudo apt --fix-broken install and sudo dpkg --configure -a, then continue with dist-upgrade. I also connected my computer to the internet via cable or USB tethering from a phone, as WiFi was not working, so apt-get update couldn't find anything.
    – hife
    Commented Dec 20, 2022 at 11:36
15

I had the same issue while upgrading my Ubuntu 18.04 to Ubuntu 20.04. some of the packages got crashed up. Mainly it is showing due to interruption of dpkg operations while booting the system.

Here's what I did to resolve this problem.

Firstly, press Ctrl+Alt+F3 together in order to open the terminal, then enter your login credentials and execute these following commands given below:-

sudo apt-get update && sudo apt-get upgrade
sudo dpkg --configure -a
sudo apt-get clean && sudo apt-get autoremove
sudo reboot

This will resolve the problem of dpkg having been interrupted.

2
  • Worked for me! Thanks! Commented Nov 14, 2022 at 13:57
  • And once again, the SAME EXACT nonworking "fix" that everybody always says will fix everything. Unbelievable.
    – John Smith
    Commented Nov 10, 2023 at 4:13
7

My question has been answered with the help of Ollie:

  • sudo apt-get update returned

    Could not get lock /var/lib/apt/lists/lock. It is held by process 22027 (focal)
    
  • I tried to identify the process with ps aux | grep -i apt and ps -aux | grep -iE "apt-get" which didn't work, but I could identify it with pgrep focal which gave me its process ID. I killed it with sudo kill <process_id>.

  • do-release-upgrade worked for me only without the -y option. It returned

    There is no development version of an LTS available.
    To upgrade to the latest non-LTS development release
    set Prompt=normal in /etc/update-manager/release-upgrades
    
  • Then I ran sudo apt-get upgrade -y and got the message 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. The 1 not upgraded was an expired libc++1 package.

Rebooting the computer, Ubuntu 20.04 worked well.

I then installed the current version of this libc++1 package via Synaptic.

4

I had the same issue on ubuntu 20, I've tried many things but what worked for me was removing the gnome and gnome-shell and reinstalling:

$ sudo apt-get upgrade && sudo apt-get update
$ sudo apt-get upgrade
$ sudo dpkg --configure -a
$ sudo apt-get remove gnome-session gnome gnome-shell
$ sudo apt-get autoremove
$ sudo apt install ubuntu-desktop
$ sudo reboot

similar to was described here. (but my problem wasn't my user)

1
  • Unfortunately, this didn't work for me on Ubuntu 20.04
    – HadidAli
    Commented Jul 20, 2021 at 10:42
4

To solve this problem in my case, I used the recovery mode option in the GRUB menu and then selected the option to start a root shell. Then I ran these commands

apt-get update && sudo apt-get dist-upgrade
apt-get clean && sudo apt-get autoremove
apt-get remove nvidia-340 

I had wrongly installed this nvidia package that was causing my issues.

2

First try to see if you can successfully login with another user account. If everything works, try deleting/moving the .config directory in your home folder.

$ rm -rf ~/.config/

This will probably delete a bunch of settings which will go back to their default values; but it solved the issue for me.

1
  • The only option that worked for me. The problem started when I was trying to change the mouse cursor using gnome-tweaks on Ubuntu 24.04. Commented yesterday
2

I got this error after upgrading to Ubuntu 24.04 (noble).

I tried

  • apt-get dist-upgrade
  • dpkg --configure -a
  • updating nvidia drivers to nvidia-driver-550
  • switching to the nouveau drivers

None of this helped.

Looking into /var/log/syslog I found the following error (formatted for readability):

gnome-shell: Received an X Window System error.
  This probably reflects a bug in the program.
  The error was 'BadCursor (invalid Cursor parameter)'.
    (Details: serial 650 error_code 6 request_code 95 (core protocol) minor_code 0)
    (Note to programmers: normally, X errors are reported asynchronously;
     that is, you will receive the error a while after causing it.
     To debug your program, run it with the MUTTER_SYNC environment
     variable to change this behavior. You can then get a meaningful
     backtrace from your debugger if you break on the mtk_x_error() function.)
kernel: traps: gnome-shell trap int3 ip:73dce93490df sp:7ffc7be2abb0 error:0 in libglib-2.0.so.0.8000.0[73dce9305000+a0000]
gnome-session: gnome-session-binary: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 5
gnome-session: gnome-session-binary: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
gnome-session-binary: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 5
gnome-session-binary: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
gnome-session-binary: Unrecoverable failure in required component org.gnome.Shell.desktop

This turned out to be a known bug.

The solution was to change the default cursor theme with the following command:

sudo ln -s -f /usr/share/icons/Adwaita/cursor.theme /etc/alternatives/x-cursor-theme
3
  • Thank you. I hit the bug while upgrading to 24.04, and the system booted into a white 'Oh no!' screen. I used your solution in Recovery mode, and my system can boot correctly now.
    – Tao Wang
    Commented Jun 5 at 18:00
  • Thank you. You just saved me a couple of hours. This worked like a charm. This should be marked as current answer Commented Jun 8 at 9:44
  • @NazmulKhan, it shouldn't, because this answers to a different question (the original post is about 20.04). I just left it here because this question comes up when searching the web about this error even in 24.04.
    – utapyngo
    Commented Jun 10 at 3:13
1

This worked for me.
Lets say you always login using: USER1
First check: If we can login to other user. Lets say other user: USER2
(Note: If you don't have another user, create a new user)
If you are successful in login using user USER2

Probably, this is issue of config file of the user.
Rename ~/.config to ~/.config.bak.
Then, try to login to that user

You can always get shell using CTRL+ALT+F2 and login with user.

1
  • 1
    After upgrade to 24.04 it happened
    – 42n4
    Commented Apr 29 at 22:31
0

I faced this problem and solved it by

First, go to tty: Ctrl + Alt + F3, and login.

Then, as dpkg was locking things, I deleted all lock log files

sudo rm /var/lib/apt/lists/lock /var/cache/apt/archives/lock /var/lib/dpkg/lock /var/lib/dpkg/lock-frontend

as described here.

Finally, I resumed the release upgrade by following the steps given in this answer.

1
  • @Ollie I don't know! Please enlighten me!
    – Rasmus
    Commented Aug 11, 2020 at 14:31
-1

when I upgrade Ubuntu 20.04 to Ubuntu 22.04 this same error occurred on my laptop.

Oh no! Something has gone wrong.
A problem has occurred and the system can't recover Please contact a system administrator

Atteched Screenshot

So I can forcibly reboot my laptop and then

Firstly, press Ctrl+Alt+F3 together in order to open the terminal, then enter my login credentials username first and then password and execute these following commands given below:-

apt --fix-broken install

1
  • 0 upgraded, 0 newly installed, 0 to remove and 42 not upgraded. Another total dud answer.
    – John Smith
    Commented Nov 10, 2023 at 4:19
-1

Same issue I have faced on Ubuntu 22.04.

I have also tried Ctrl + Alt + F3 but i gets stuck at a blinking cursor (_)

Then I forced to turn off my computer by pressing the Power button.

And again turn on my computer while starting boot press Shift key And select Advance options for ubuntu

And then select your preferred kernel version with (Recovery mode)

In the recovery mode menu, you'll have various options to troubleshoot your system, such as repairing broken packages or dropping to a root shell.

First try repairing broken packages and reboot your computer.

If repairing broken packages not solve your issue then try the above method.

sudo apt-get update && sudo apt-get upgrade
sudo apt-get remove package_name
sudo apt-get purge remove package_name
sudo reboot

Replace package_name with the actual package name that affected your computer.

BTW If you want to check the installed package list then try dpkg --list

-1

Some issue on Ubuntu 23.04

Somehow my ubuntu doesn't work with nvidia graphics card.
So you need to run sudo prime-select intel in recovery mode shell terminal.
It helped me.

-1

So, I ran into this super annoying thing after Ubuntu decided to auto-update itself 🙄. I'd put in my password, see the "Oh No! Something's gone wrong" screen, and get kicked right back to the login page. Super fun times.

Here's what I did to figure things out:

Booted into Ubuntu recovery mode because, well, regular mode wasn't letting me in.

Dug into some logs Inspected /var/log/syslog

Checked /var/log/lightdm/xorg.0.log.

Reviewed /var/log/gdm3/xorg.0.log.

(all those /var/log/... ones) - felt like a detective, not gonna lie. Stumbled upon this pesky ~/.Xauthority file causing some drama. The thing had its permissions all messed up! The Real MVP Solution:

Fixed the file's permissions with:

sudo chmod 755 ~/.Xauthority

That's like telling the file to behave nicely with everyone.

Tried logging in with Xorg... nope, still acting up. Switched to Wayland at the login screen and voila! 🎉 I was in! TL;DR: If you can't log into Ubuntu after an update, check if ~/.Xauthority is acting up and maybe give Wayland a shot.

Anyone else faced this? Or maybe there's a pro out there who knows how to keep the peace with Xorg?

-1

For Armbian Systems
If your system is an Armbian, this problem is caused by the libegl-mali-xlnx package, remove it with:

sudo apt remove libegl-mali-xlnx

After, reboot your system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .