13

I have a Dell XPS 15 9570 with a Dell WD19 Dock and on this Dock I have 2 Monitors. The internal Monitor of the Notebook is off but the Lid is open.

I have installed Ubuntu 20.04 LTS.

Everything is working fine, except the following Icon in the Top bar is blinking (Appearing and Disappearing). I don´t know what that is. It looks like a cord but the Notebook charging as expected.

enter image description here

It blinks sometimes in a faster and another Time in a slower speed -> Something between 2 - 5 Seconds.

Appearing:
enter image description here

Disappearing:
enter image description here

The Dock are the complete Time connected.

Exact behavior: It's blinking when I have connected my Laptop to the WD19 Docking Station. It's not blinking when I connect my Laptop ONLY to the normal Power Cord or have NO connection to Dock and Power Cord. But it's also blinking when I connect to the Docking Station AND the normal Power Cord.

Do anyone knows what this means? And how can I stop this? It's really annoying when some icons jumping all the time left and right!

Here I found some logs. Maybe this is the Event:
enter image description here

4
  • Have you tried clicking on it/right-clicking on it? – matt freake May 13 '20 at 12:10
  • Does the cable icon blink even when the laptop is not connected to the power source? On Dell laptops the power light is blinking means that the laptop is receiving power from the wall source and a sequence of three dots usually stands for settings. – karel May 13 '20 at 12:10
  • @mattfreake It's not possible to click left or right on it -> A click in this Area open or closes the "Top Menü" (Network, Audio, Setting, Power, Logoff and so on) – dkleber89 May 13 '20 at 12:21
  • @karel It's blinking when i have connected my Laptop to the WD19 Docking Station ... It's not blinking when i connect my Laptop ONLY to the normal Power Cord or have NO connection to Dock and Power Cord... But it's also blinking when i connect to the Docking Station AND the normal Power Cord – dkleber89 May 13 '20 at 12:27
3

The image is known as a cable snake:

boltd cable snake

From the author's blog:

GNOME Shell

The GNOME shell bits to enable Thunderbolt 3 support were merged some time ago and made it into 3.28. This means that the GNOME shell will act as authorization agent and will automatically authorize new thunderbolt 3 devices — if the user has administrator rights, is currently logged in and the session is unlocked. It will also show a little indicator (called the cable_snake by some) in the status indicator section while devices are being authorized because the whole authorization dance can take quite a while.


Correspondence from developer

I emailed the developer today and this is our conversation:

There are users annoyed with Cable_Snake icon making icons shift left and right in the application indicator top bar. Is there a way to disable the icon but keep boltd running?

This was introduced via a change in the kernel/udev, but a work-around laded in bolt 0.9: https://gitlab.freedesktop.org/bolt/bolt/-/issues/156

There is an ubuntu bug open: https://bugs.launchpad.net/ubuntu/+source/bolt/+bug/1892657

Is there a way to disable the icon but keep boltd running?

Currently not, GNOME Shell is hardwired to react to boltd's probing setting. Best way is to update bolt.


Some ideas of my own

I use the Unity interface where application indicators are right justified on the top bar so new apps opening and closing on the left are preferred and not a disadvantage.

For Gnome Users to prevent icons jumping back and forth the only band-aid I can think of is moving all icons to the right side. This can probably be achieved here:

If this works, then when the boltctl icon appears and disappears on the left side nothing "jumps around".

1

Disclaimer - I will post some information even though it's not the solution for the problem but maybe others can pitch in and provide more information to find the solution.

The process causing appearing is boltd/boltctl. As in Dumitru Alexandru Surdu's answer is described you can check what's happening with boltctl monitor. You will message Probing started when icon appears and Probing done when icon disappears. Now, you could disable boltd service but I do not think you would want that since this service manages thunderbolt.

Strictly speaking this is not a bug because icon just shows what's happening in the background but it is very annoying. I guess we can call it UX bug.

If anyone finds a solution or some other information how we can solve it (where to report this kind of problem?), please comment or edit.

0

I solved the problem by changing in the BIOS settings the battery charging mode from "Adaptive" to "Primarily AC".

Update:

I was wrong about the AC from BIOS.

After stopping and disabling boltd all fixed. You can check by using boltctl monitor and each time is probing the icon pops up.

3
  • 1
    Nice ... Can u provide a Step by Step Solution for stopping and disabling boltd? – dkleber89 Jun 26 '20 at 4:43
  • I don't understand the answer. Do the update in Bios from "Adaptative" to "primarily AC" work?. If not, I suggest editing the answer to the simplest way to follow it. – heracho Aug 20 '20 at 19:12
  • If you are using a thunderbolt dock, disabling boltd is not a realistic option. See the descriptive answer by WinEunuuchs2Unix: askubuntu.com/a/1270227/8570 – Cas Sep 9 '20 at 15:03
0

Do you have installed any power managment software like tlp or powertop? I had the same situation with ThinkPad TB3 dock station. After investigation I found that problem was with auto suspending one of the dock station USB devices. So I added this device to the blacklist for tlp and the problem is gone.

I'm not sure that it's only UX problem. For me it's a problem with timeouts during the probing. You can check it using journalctl

For example:

lukasz@lukasz-ThinkPad-T480:~/.config$ sudo journalctl | grep bolt | grep probing | head -15
Aug 25 10:30:01 lukasz-ThinkPad-T480 boltd[750]: probing: adding /sys/devices/pci0000:00/0000:00:1d.0/0000:04:00.0 to roots
Aug 25 10:54:13 lukasz-ThinkPad-T480 boltd[803]: probing: adding /sys/devices/pci0000:00/0000:00:1d.0/0000:04:00.0 to roots
Aug 25 12:00:33 lukasz-ThinkPad-T480 boltd[797]: probing: adding /sys/devices/pci0000:00/0000:00:1d.0/0000:04:00.0 to roots
Aug 25 12:03:14 lukasz-ThinkPad-T480 boltd[797]: probing: started [1000]
Aug 25 12:03:17 lukasz-ThinkPad-T480 boltd[797]: probing: timeout, done: [2993558] (2000000)
Aug 25 12:03:18 lukasz-ThinkPad-T480 boltd[797]: probing: started [1000]
Aug 25 12:03:20 lukasz-ThinkPad-T480 boltd[797]: probing: timeout, done: [2001230] (2000000)
Aug 25 12:03:28 lukasz-ThinkPad-T480 boltd[797]: probing: started [1000]
Aug 25 12:03:31 lukasz-ThinkPad-T480 boltd[797]: probing: timeout, done: [3000271] (2000000)
Aug 25 12:03:33 lukasz-ThinkPad-T480 boltd[797]: probing: started [1000]
Aug 25 12:03:36 lukasz-ThinkPad-T480 boltd[797]: probing: timeout, done: [2996276] (2000000)
Aug 25 12:03:37 lukasz-ThinkPad-T480 boltd[797]: probing: started [1000]
Aug 25 12:03:39 lukasz-ThinkPad-T480 boltd[797]: probing: timeout, done: [2000769] (2000000)
Aug 25 12:04:31 lukasz-ThinkPad-T480 boltd[797]: probing: started [1000]
Aug 25 12:04:34 lukasz-ThinkPad-T480 boltd[797]: probing: timeout, done: [3000758] (2000000)

So, for the good experiences with dock station I advise resolve the problem.

0

As detailed by @WinEunuuchs2Unix this is a boltd bug however I have found a usable workaround until a fix is backported to 20.04 Focal.

Install the Panel Indicators extension that moves the power/network icons to the status area and the 'cable-snake' will never appear.

https://extensions.gnome.org/extension/3022/panel-indicators/

Edit: The above url is now dead but it was a fork of the following extension so look for other forks with recent fixes:

https://extensions.gnome.org/extension/2416/panel-indicators/

enter image description here

Much better than a dancing status bar!

2
  • The link to the extension tells "404 - Page not Found We couldn't find the page you were looking for, /extension/3022/panel-indicators/" Did you get the extension, or at least found it was active, on Sep 9? That would mean it was removed shortly ago... – sancho.s ReinstateMonicaCellio Dec 23 '20 at 20:26
  • It was active when I was using it, this is the source code: github.com/pemmoura/panel-indicators – Cas Dec 29 '20 at 11:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.