6

I have been trying to get any vnc setup to work for me.. that issue is posted elsewhere.. but one issue in particular now has come up..

I installed and removed tigervnc, but now tightvncserver complains it cannot startup... how do I create a new xvnc-session?

inside myxvncserver:1.log

13/05/20 10:46:40 Xvnc version TightVNC-1.3.10
13/05/20 10:46:40 Copyright (C) 2000-2009 TightVNC Group
13/05/20 10:46:40 Copyright (C) 1999 AT&T Laboratories Cambridge
13/05/20 10:46:40 All Rights Reserved.
13/05/20 10:46:40 See http://www.tightvnc.com/ for information on TightVNC
13/05/20 10:46:40 Desktop name 'X' (2600k:1)
13/05/20 10:46:40 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
13/05/20 10:46:40 Listening for VNC connections on TCP port 5901
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
/etc/X11/Xvnc-session: 6: vncconfig: not found
Killing Xtightvnc process ID 17651
~                                                                                                                                                               
~                                                                                                                                                               
~ 

I searched elsewhere and someone states "oh just get a new xvnc-session" since tigervnc apparently deletes it (thanks tigervnc)

how do I fix this, so I can connect to ubuntu 20.04 via my mac?

4
  • You can use ssh and X11 forwarding to connect to your Linux machine from your mac
    – ldias
    Commented May 19, 2020 at 15:26
  • ive reinstalled the entire OS... forwarding X was not working from Mac
    – Erik
    Commented May 19, 2020 at 20:33
  • Is X12 forwarding enabled in your SSH configuration? See this article for how to setup and use X11:businessnewsdaily.com/11035-how-to-use-x11-forwarding.html
    – ldias
    Commented May 19, 2020 at 20:39
  • Please post the output of head -n6 /etc/X11/Xvnc-session|tail -n1
    – leggewie
    Commented May 20, 2020 at 18:46

1 Answer 1

5
+50

Try sudo apt purge tigervnc-standalone-server

What I believe is happening is that you deinstalled the tigervnc-standalone-server package but you did not purge it, thus leaving its configuration such as /etc/X11/Xvnc-session and others installed and active.

3
  • i lost patience and just reinstalled the OS, but will give you a check for answering with something very likely .. I indeed didn't purge
    – Erik
    Commented May 21, 2020 at 14:35
  • 1
    This fixed the exact same issue for me after I'd been struggling with it all afternoon. I had removed tigervnc-standalone-server, but it left /etc/X11/Xvnc-session in place, and that turned out to be what was breaking tightvnc server. Probably could have just deleted that file, but the purge deleted it, and then tightvnc server started working again. Thanks. Commented Aug 27, 2021 at 1:11
  • 1
    Saved my life with this after I had a warning about a lock file on restart of a tightvnc service, removed the lock file, then service would not restart without an error from gnome-session-binary.
    – JDQ
    Commented Nov 16, 2022 at 8:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .