0

I bought a new laptop (Dell 3493) and moved my installation disk from my old one. I had in it the 18.04 LTS and after some troubles I decided to update to 20.04 LTS. I got everything to work except those 3 programs, which never start.
This is what I got with Shotcut:

No appenders associated with category qt.network.ssl [Warning] <> QSslSocket: cannot call unresolved function SSLv23_client_method No appenders associated with category qt.network.ssl [Warning] <> QSslSocket: cannot call unresolved function SSL_library_init Segmentation fault (core dumped)

This is what Kdenlive shows:

MLT ERROR: "[consumer sdl2_audio ] Failed to initialize SDL: Could not setup connection to PulseAudio"

org.kde.knotifications: Audio notification requested, but sound file from notifyrc file was not found, aborting audio notification Segmentation fault (core dumped)

And this is what I got from Blender:

Writing: /tmp/blender.crash.txt Segmentation fault (core dumped)

About Kdenlive, when I use the snap version on the official ppa got as well a Segmentation fault (core dumped). I couldn't find proper answers in the web (by the way, I've tried to reinstall an reboot a couple of times those apps).

  • "moved my installation disk from my old one" - since you have new hardware now, you ought to do a clean install. All your software was installed to work with your old device. – Nmath May 14 at 1:45
  • Ok, I was considering that. I'm going to create a clean instalation of 19.10 to see if everithing works better. Do you think would be necesary to create a new /home disk as well? I have them separated. – mekax May 15 at 4:23
  • it depends on whether a config file under /home is causing your problem. FYI 19.10 is EOL (end of life) in July, so if you don't want to have to immediately upgrade again, you may want to just use 20.04, which won't be EOL until 2025 – Nmath May 16 at 3:59
0

The problem seems not limited to three programs mentioned in the question. According to this answer it is a bug in mesa drivers. Adding following line to .profile seems let the programs start (I can confirm it for Blender and Kdenlive)

MESA_LOADER_DRIVER_OVERRIDE=i965

However it is not a proper fix and we have to wait for the problem to be solved in drivers.

| improve this answer | |
1

For kdenlive had the same problem. I resolved it using the appimage from the official web site. Maybe you can do the same with blender and shortcut…

  • remove kdenlive
  • download appimage from the official website: wget https://files.kde.org/kdenlive/release/kdenlive-20.04.1b-x86_64.appimage -O ~/Downloads
  • install appimage library: sudo apt install libappimage0
  • add execution bit to the .appimage file: chmod +x ~/Downloads/kdenlive-20.04.1b-x86_64.appimage
  • execute the file ~/Downloads/kdenlive-20.04.1b-x86_64.appimage
| improve this answer | |
  • Thanks, I will try! I did as @Nmath said and made a clean installation of Focal Fossa. I got everything working just fine, but I triyed to install some audio packages from the Ubuntu Studio Installer app, and also I installed Virtual Box and Genymotion. After that Kdenlive again got broken (but not Blender or my video reproduction, so it is a good sing). I guess there's some difficulties between Kdenlive and Jack, but we will see. – mekax May 27 at 19:57
  • UPDATE: about an easy solution to the troubleshouting between Kdenlive and Jack, see here: medium.com/@ayubaswad/… Seems to work for me. – mekax May 27 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.