2

I recently purchased Dell XPS 13 (2020) Developer Edition with Ubuntu 18.04 pre-installed. I would like to try elementary OS on the machine. I followed the instructions here and created bootable USB drive. Now when I try to boot using the USB drive, the Ubuntu screen shows with the "ERROR: This recovery media only functions on Dell and Alienware systems" message (error message screenshot here).

I'm aware that similar issue was discussed before here, here and here. I tried all proposed suggestions which included disabling/enabling Secure Boot and SecureAssist in the BIOS, and using Legacy Boot option. The latter is disabled in the latest version of BIOS installed on my machine (v 1.0.7) and only UEFI boot is available (BIOS boot options screenshot here).

Question: Does anyone know what I can do to bypass the Dell Recovery routine when booting from USB drive, given that legacy boot is not available and given that disabling Secure Boot does not help?

Thank you in advance for the help.

UPDATE: It seems also that the issue is at least partially related to elementary OS, since I managed to boot from live USB into Ubuntu 20.04 with no problem after disabling Secure Boot in the BIOS.

3
  • I have the same issue, were you able to find your way ? May 13 '20 at 6:58
  • @NicolasPenin, no unfortunately no one replied yet. May 13 '20 at 13:56
  • Do you have a setting to turn on or allow USB boot? It seems like it is default booting the internal recovery ISO, not the USB. Are you sure your Elementary installer is correct or that flash drive is correct. Dell 7700 pre-installed 18.04, 20.04 works ubuntuforums.org/showthread.php?t=2443622
    – oldfred
    May 22 '20 at 21:02
0

Removing hidden Ubuntu partition allows to install Elementary OS.

2
  • My machine came with 3 partition: EFI System, Microsoft Reserved and Linux Filesystem. Which of those (presuming not the last one) should I remove? Or do you mean removing one of the BOOT options from the list? If yes, which one is the UBUNTU hidden one? I tried deselecting everything besides the USB drive in that list before, but still had the same issue. May 22 '20 at 17:20
  • 1
    my notebook came with ubuntu 18.04 preinstalled, in the bios i have efi, an ubuntu hidden partiion (5gb) and the ext4 partition where ubuntu were running, i removed the 5gb partition and it let me install elementary os. previusly i made an image of that partition just in case.
    – Pelado
    May 23 '20 at 0:53
0

Deleting the ~5GB partition called "Windows Reserved" using the Disks application in Ubuntu will let Elementary OS install normally.

There were no BIOS changes required on my part, but SecureBoot was already disabled on my machine, so YMMV.

1
  • Deleting the MSR partition can destroy an existing Windows installation, especially if you are using BitLocker. It could cause data on an encrypted partition to be unrecoverable. FYI: Elementary OS is generally not on-topic unless it is helpful for users of Ubuntu (I've requested the question to be migrated)
    – Nmath
    Sep 28 '20 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.