31

My Google calendar notifications keep popping up. Every single one of them. I have turned off Firefox notifications in the Settings menu. I tried this but there is no preference menu in my Ubuntu 20.4.

Example:

Example

Please, does anyone know how to turn off the calendar pop ups?

1
  • This notification is caused by the evolution-data-server package, but DO NOT TRY TO REMOVE IT! Both ubuntu-desktop and gdm3 depend on it and you will boot to a text shell the next time you reboot
    – Boltgolt
    Jan 6 at 20:00

4 Answers 4

28

If you added online accounts, go to settings > Applications > calendar, then turn off notifications

Or you can go to settings > online accounts > google account the calendar option

4
  • 6
    This didn't work for me in Ubuntu 20.10
    – Flimm
    Mar 4, 2021 at 14:25
  • 1
    The calendar option is not available in my Applications tab. Deactivating the calendar option in the Google Account did not change anything. Apr 13, 2021 at 6:29
  • sometimes it can be other things. If you don't want them at all, try askubuntu.com/a/1297664/1025264.
    – Twilight
    Apr 13, 2021 at 22:15
  • I can confirm this works for me in 20.04.
    – waldyrious
    Aug 12, 2021 at 13:55
20

You can suppress the ugly pop-up window – but keep the less obtrusive Gnome Shell notification – by setting /org/gnome/evolution-data-server/calendar/notify-with-tray in dconf.

I discovered this from a comment in a related evolution-data-server bug report (GNOME/evolution-data-server#60).

Option 1: Use dconf Editor

Install dconf Editor if it's not already installed:

sudo apt install dconf-editor

Launch dconf Editor:

enter image description here

Navigate to /org/gnome/evolution-data-server/calendar and set notify-with-tray to "on":

dconf-notify-with-tray

Option 2: Use gsettings

Alternatively, a quicker way to turn this setting on is to issue following command in the terminal:

gsettings set org.gnome.evolution-data-server.calendar notify-with-tray true
2
  • 1
    This didn't work for me (either via the dconf GUI or gsettings) in Ubuntu 20.04 Sep 1, 2021 at 13:02
  • Does not work in Ubuntu 20.04 either for me Dec 2, 2021 at 7:53
11

Currently it's the way how evolution notification daemon is working. If u want to disable just reminders, but keep notifications you can do it by so:

  • Copy the file /etc/xdg/autostart/org.gnome.Evolution-alarm-notify.desktop to your local .config/autostart folder.
  • Open the copy with a text editor, and change the line OnlyShowIn=GNOME;Unity;XFCE;Dawati;MATE; to NotShowIn=GNOME;

Now keep in mind, that you can replace GNOME by any distro you're using.

You need to log out then back in for the change to take effect.

3
  • It would be nice to disable just the sound, as it makes an annoying alarm clock sound.
    – Kaigo
    Nov 25, 2020 at 10:11
  • I think you need to log out and log in again for the changes to take effect.
    – Flimm
    Mar 4, 2021 at 14:27
  • In Ubuntu 21.04, the instructions are the same, except you only need to add the line NotShowIn=GNOME. You don't need to delete the existing line as it doesn't exist any more.
    – Flimm
    Jun 8, 2021 at 14:55
0

Switch of the notifications of "Evolution Alarm Notify" without any need to open scripts or files just like so:

  1. Search for Notifications in Ubuntu's search bar (hit the windows key), which is a menu point of the Settings. It looks like

enter image description here

  1. Click on "Evolution Alarm Notify", which looks like

enter image description here

  1. Switch off as per your preferences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.