0

Today I installed Ubuntu 20.04 on my Lenovo L380 Yoga laptop. The install went fine and all of the hardware seems to work until I shutdown or restart the unit. If the power cord is connected during boot, the laptop will not boot and won't even get far enough into booting to show the Lenovo splash screen. It just sits at a dark blank screen. No response to the keyboard. If I disconnect the power cord at this point, the booting will continue as normal and things seem fine.

If I boot the laptop without the power cord attached in the first place, it boots fine. I have also tried this with Fedora 32 and I got the same results. Prior to this day, I've only had the factory installed Windows 10 on this laptop. (I've successfully run Linux on other laptops too)

Any thoughts?

2
  • Report it as a bug by running ubuntu-bug linux.
    – Pilot6
    May 12 '20 at 19:43
  • 1
    Lenovo says the Yoga BIOS design for Yoga machines precludes Linux install, so I'm not surprised. See Lenovo's own statement on the subject news.lenovo.com/pressroom/press-releases/…
    – K7AAY
    May 12 '20 at 19:46
0

Seems like it has something to do with changes in the latest firmware initialization package version 1.16 r0ruj17w (UEFI BIOS 1.24 r0ret41w and ECP 1.14 r0rht31w). Downgrading to 1.15 r0ruj15w solved the reboot issue for me. This should be reported to Lenovo. Here is the FW init package download page https://support.lenovo.com/cl/en/downloads/ds502400.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.