Upon opening, both RStudio and Steam follow the exact same pattern. They will spend a second or two on my panel, giving the impression that they're opening, Steam will even try to update for a moment, and then they will start to take up about 3GB of RAM and then crash. Steam gives no errors, but RStudio gives a crash report page that contains "rsession crashed with SIGABRT in raise()".

I did try to purge and reinstall Steam, and I also deleted /home/.steam and /home/steam/, and this did work. In fact, it even managed to updated a few times. However, once these updates were done, the above issue returned.

Where can I investigate these issues? What parts of my hardware/software configuration may be relevant? I'm currently running Xubuntu 20.04 on a Lenovo S340 Ideapad. I was previously running 19.10.

As requested, strace steam is here. Opening RStudio in the terminal gives this incomprehensible output and strace rstudio returns complete madness that is beyond my ability to paste anywhere (it's 12MB).

Installing the Solus version of Steam instead of the official (.deb) version did not fix this problem, nor did any installations of helpful-looking graphics drivers or 32-bit libraries.

UPDATE: The comments from duckmayr have fixed RStudio (see the permanent solution here, the temporary one didn't work for me) and this fix suggests that this is a graphical issue. In support of this claim, I've also discovered that VLC Media Player will play audio files but not video files. If it's any help, my graphics card is an Intel Corporation UHD Graphics 620 (Whiskey Lake). I believe that it's integrated.

  • Please add log for ``` strace steam ``` If strace not found, run apt install strace – Ivan Borshchov May 12 at 19:23
  • See new edit to question. – J. Mini May 12 at 19:29
  • 1
    Regarding RStudio, does switching to software rendering help? (see support.rstudio.com/hc/en-us/articles/… for instructions and community.rstudio.com/t/rstudio-crashing-at-startup/29883/2 for discussion of this in the context of a similar issue) – duckmayr May 13 at 0:21
  • 1
    @duckmayr Hey, that worked! For whatever reason, the temporary solution (export RSTUDIO_CHROMIUM_ARGUMENTS="--disable-gpu" /usr/lib/rstudio/bin/rstudio) does nothing, but the permanent solution of editing the file in ~/.config/RStudio/ worked! Does this suggest something about the source of my issue? – J. Mini May 13 at 0:30
  • I think this means that RStudio's default rendering engine is not playing well with the graphics drivers. It's a little beyond my ken, but I'm glad I could point you in the right direction. Got no clue on Steam though ¯_(ツ)_/¯ – duckmayr May 13 at 0:33

Apparently it's this bug. Add 'export MESA_LOADER_DRIVER_OVERRIDE=i965' to /home/[username]/.profile to fix.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.