1

XUbuntu 18.04.4 LTS, dual boot on hp spectre x360

Sometimes, when connected to ethernet (via usbc/ethernet hub, my hardware does not have an ethernet port), a software glitch happens. It seems to me that every process that involves networking becomes unresponsive. For example, "ping google.com" in this situation does not respond to stopping or terminating. I notice the same thing with other processes, for instance "service network-manager restart." Further, after the glitch happens, it seems like the system cannot properly reboot. It gets stuck at some point booting down, and becomes unresponsive. The only way out seems to be to forcibly power off the machine.

Strangely the ethernet connection works until this glitch happens, and the glitch does not always happen. But it happens frequently enough and with dire enough consequences that I want to figure out what is going on and how to stop it.

I have tried to pinpoint what causes the glitch. Most significantly, I have tried but not been able to reproduce the glitch while booting off of the same live USB that I used to install xubuntu in the first place. In addition, I am able to reproduce the glitch on a new user account on my current installation. Together these two findings suggest to me that the glitch may be caused by a non-default system-wide configuration setting. The only trouble is I do not know what to do to pinpoint that and change it, which is why I would reach out for help.

Also relevant: the glitch seems to happen only when I am connected to the ethernet cable and at the same I attempt to connect to the wifi network which comes from the same router I am connected to on ethernet.

How should I proceed, in order to pinpoint the issue here?

  • What is your switch set to? If it's locked down to, say, 100 Mbps full duplex, and the adapter tries something else, it could cause that problem. I would substitute a different brand of USB-C to Ethernet adapter. – K7AAY May 12 at 17:35
  • 1
    That is interesting. How do I check what my switch is set to? Also, this doesn't explain why the bug is not reproduced on the liveUSB (and the same adapter). – George Hauser May 12 at 17:45
  • If the adapter's setting in your permanent install does not match what the switch expects, but the LiveUSB settings are different, could explain it. What's the speed and duplex setting chosen by your LiveUSB? Does that match your permanent install? What is the speed of an unladen swallow? – K7AAY May 12 at 17:50
  • 1
    I ran lshw -C network on the liveusb (<) and permanent install (>). The important data regarding your questions (output from diff | grep size\|speed\|duplex) < size: 100Mbit/s > size: 10Mbit/s < configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.10 duplex=full ip=192.168.0.15 link=yes multicast=yes port=MII speed=100Mbit/s > configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.09.11 duplex=half link=no multicast=yes port=MII speed=10Mbit/s What in the world do you mean? African or European? – George Hauser May 12 at 18:53
  • 1
    Okay so you have helped me quite a lot. The only thing I need further is a suggestion for how to go about changing the settings on my permanent install to match the ones that work on the liveusb. Thank you so much! – George Hauser May 12 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.