9

With fresh-installed 20.04 sometimes I get almost completely frozen GUI. Almost completely -- I mean I can not do Alt+F2 and r. And while the mouse pointer still moves, the system does not respond to mouse clicks or keyboard buttons.

I already have found out that in 20.04 to switch to another tty you can not use F1 or F2 in well-known Ctrl+Alt+F# combination -- only F3 and further. And to return to GUI you press Alt+F2 combination.

To summarize, I can switch to another text-mode tty, but how do I restart gnome-shell from there? I tried several commands, but neither succeeded. And the result was either error message or loosing the session and closing working programs. Of course, in the second case I have to wait for another freeze to test some another command. So the main question is:

How do I restart gnome-session from another tty in a way, similar to Alt+F2 and r specifically in 20.04 ?

UPD:

Several minutes ago I got more severe freeze. I could move the mouse pointer, but the system did not respond even to Ctrl+Alt+F# combination, and I could not switch to another tty. So the next question:

Does the ability to move the mouse pointer mean that some part of the system is still alive and I could possibly interact with it, and how do I do it if I stuck to GUI and can not switch to another tty with Ctrl+Alt+F# combination? Again specifically in 20.04

8
  • 1
    does that help: askubuntu.com/questions/100226/…
    – pLumo
    May 12, 2020 at 13:41
  • Edit your question and show me ls -al ~/.local/share/gnome-shell/extensions and ls -al /usr/share/gnome-shell/extensions and free -h and sysctl vm.swappiness. Start comments to me with @heynnema or I may miss them.
    – heynnema
    May 12, 2020 at 14:00
  • @heynnema askubuntu.com/a/1239883/232433
    – Oleksandr
    May 15, 2020 at 12:41
  • If you'd respond to my request for more information, maybe I could help you. Also show me ls -al /var/crash.
    – heynnema
    May 15, 2020 at 13:10
  • You can re-enable the virtual terminals by calling sudo nano /etc/systemd/logind.conf and then uncommenting NAutoVTs=6.
    – Joschua
    Oct 7, 2020 at 17:29

1 Answer 1

0

Have you tried
RightAlt+F2 r Enter”?

Unless it was coincidence, the LEFT Alt key did nothing.

This has been frustrating me for a long time as well. LeftAlt did not do anything but RightAlt did.

Regained responsiveness and did not lose any apps, but the Desktop Environment or Gnome Menu disappeared. Have to figure out the gnome-session(?) equivalent of explorer.exe.

PopOS 20.04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .