3

I have two monitors connected to my laptop, one via DisplayPort and one via HDMI. My speakers are connected to my DisplayPort monitor and normally all works fine with audio output device set to "HDMI/DisplayPort 3 - Built-in Audio" and sound coming out of my speakers.

When working as expected my audio output devices (both in settings and pulseaudio volume control) are:

  • HDMI/DisplayPort 3 - Built-in Audio (SELECTED)
  • HDMI/DisplayPort - Built-in Audio
  • Headphones - Built-in Audio

BUT sometimes (not always) when waking from suspend my DisplayPort output is missing and I get no sound so the devices shown are just these:

  • HDMI/DisplayPort - Built-in Audio
  • Headphones - Built-in Audio

Is there any way to reset/restart the sound system or have it re-scan for output devices? Any way to go about debugging this issue next time it happens? I have not found any way of solving this so far.

Also, possibly related to the problem above, even if not missing a device, the system often reverts to one of the other output devices on a reboot or wake, it won't always be set to the output I previously chose.

  • Ubuntu 20.04 LTS (although this was happening on previous versions).
  • Gnome 3.36.1
  • X11 windowing
  • Nouveau drivers on Intel HD graphics

Any help or advice appreciated, thanks.

3

This has recently happened to me on a new install (20.04) - not consistently, but sometimes after waking up, my preferred audio output device is just missing.

I had success by restarting pulseaudio (both gdm and my user's one), by doing sudo killall pulseaudio (pulseaudio -k seemed to do nothing), and then restarting the pulseaudio user daemon with systemctl --user restart pulseaudio.service. I'm not sure everything is completely happy (the gdm user was running a pulseaudio instance as well) and pavucontrol seems to segfault on exit now, but at least audio is running again.

3
  • Thanks. But I don't seem to have a pulsaudio.service. If I grep for pulseaudio I have /usr/bin/pulseaudio --daemonize=no --log-target=journal and doing the killall you say above does not kill that process. – codlord May 14 '20 at 14:20
  • It happened again today so I did sudo killall pulseaudio then systemctl --user restart pulseaudio.service but that said Warning: The unit file, source configuration file or drop-ins of pulseaudio.service changed on disk. Run 'systemctl --user daemon-reload' to reload units. so I did systemctl --user daemon-reload then tried another killall/restart. At every stage my HDMI/DisplayPort 3 audio device is still missing :-( – codlord May 20 '20 at 18:37
  • I found that my webcam was interfering with this, unplugging it and running the commands above worked for me. – Amir T Oct 24 '20 at 13:23
0

I may have at least found a workaround to solve this issue even if it's not really discovering what causes it or really solving the issue in an ideal way. But in case anyone else has the same problem and has two monitors:

I went to Ubuntu settings Screen Display section, disabled the monitor which has the missing HDMI/DisplayPort 3 audio device, clicked Apply then re-enabled and clicked Apply. Then going to Sound settings section all 3 audio devices are shown again.

At least this works around the issue without a reboot so better than nothing!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.