0

I am trying to install cmake on ubuntu 20.04

sudo apt isntall cmake

everything starts fine, but downloading of package stuck

Get:1 http://archive.ubuntu.com/ubuntu focal/main amd64 cmake-data all 3.16.3-1ubuntu1 [1,612 kB] 95% [1 cmake-data 1,509 kB/1,612 kB 94%

I tried different servers as main, US, Slovak but without any change

Any clues how to solve this?

The system is installed in VMware, win 7 as host

Changing mirror, cleaning cache, fresh installation of ubuntu 20.04 did not help.

Installing any other package works

2
  • Goes smoothly here on the NL server. – Jos May 12 '20 at 7:35
  • Tried NL server, same problem – michal May 12 '20 at 8:26
0

Maybe your package download have been corrupted. In such cases do

sudo apt clean && sudo apt update

Then repeat your installation command again. Changing to other mirror also could help in some cases.

You could also try to download it:

$ sudo apt download cmake-data
Get:1 http://archive.ubuntu.com/ubuntu focal/main amd64 cmake-data all 3.16.3-1ubuntu1 [1 612 kB]
Fetched 1 612 kB in 11s (150 kB/s) 

$ ls | grep cmake
cmake-data_3.16.3-1ubuntu1_all.deb

$ sudo apt install ./cmake-data_3.16.3-1ubuntu1_amd64.deb

You could also try to download it directly using wget:

wget -c http://archive.ubuntu.com/ubuntu/pool/main/c/cmake/cmake-data_3.16.3-1ubuntu1_all.deb

Also, try to use different network configuration settings: use bridge instead of NAT and vice versa. If your host PC is connected through wi-fi, try to use a different wi-fi hot spot, as it also could be the cause of apt errors.

Installing cmake using Ubuntu Software is also could be used as an alternative way.

3
  • Didn't help, even fresh installation of ubuntu in VMware – michal May 12 '20 at 9:31
  • Finally I installed cmake via Ubuntu Software, seems work fine. Anyway download cmake-data still not working – michal May 12 '20 at 10:27
  • Ok, I'll include this option to the answer, so you could accept it if you want – Gryu May 12 '20 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.