0

I've been battling this issue for a few weeks- after switching to 20.04 from eoan and repartitioning, I have lost touch input on my Thinkpad X380 Yoga screen. Indeed, the problem persists on my Windows partition as well. I tried all my tty inputs and inputattaching drivers for w8001 and wacom_iv to no avail. Further, I redownloaded all kernel drivers and X input drivers from the Linux Wacom project and still got nothing.

Pen input is completely functional, however; including pressure sensitivity.

Some useful info:

    me@computer:~$ sudo evtest
    No device specified, trying to scan all of /dev/input/event*
    Available devices:
...(other stuff)...
    /dev/input/event4:  AT Translated Set 2 keyboard
    /dev/input/event5:  Video Bus
    /dev/input/event6:  ETPS/2 Elantech TrackPoint
    /dev/input/event7:  ETPS/2 Elantech Touchpad
    /dev/input/event8:  Logitech USB Optical Mouse
    /dev/input/event9:  Wacom Pen and multitouch sensor Finger
    /dev/input/event10: Wacom Pen and multitouch sensor Pen
...(other stuff)... 
    Select the device event number [0-19]: 9
    Input driver version is 1.0.1
    Input device ID: bus 0x3 vendor 0x56a product 0x5155 version 0x111
    Input device name: "Wacom Pen and multitouch sensor Finger"
    Supported events:
      Event type 0 (EV_SYN)
      Event type 1 (EV_KEY)
        Event code 330 (BTN_TOUCH)
      Event type 3 (EV_ABS)
        Event code 0 (ABS_X)
          Value      0
          Min        0
          Max    11748
          Resolution      40
        Event code 1 (ABS_Y)
          Value      0
          Min        0
          Max     6604
          Resolution      40
        Event code 47 (ABS_MT_SLOT)
          Value      0
          Min        0
          Max        9
        Event code 53 (ABS_MT_POSITION_X)
          Value      0
          Min        0
          Max    11748
          Resolution      40
        Event code 54 (ABS_MT_POSITION_Y)
          Value      0
          Min        0
          Max     6604
          Resolution      40
        Event code 57 (ABS_MT_TRACKING_ID)
          Value      0
          Min        0
          Max    65535
    Properties:
      Property type 1 (INPUT_PROP_DIRECT)
    Testing ... (interrupt to exit)

and, of course, I had to interrupt due to no input being detected.

Any suggestions going forwards would be appreciated. Its worth noting that I do not know which tty port corresponds to pen for sure as I was unable to get any feedback when sudo screen /dev/ttySx was applied for all x on my machine. Specifically, I always get "[screen is terminating]" back.

1
  • @K7AAY Interesting, though I did had it working with my prior install for eoan. The main difference is that I had to repartition everything and reinstall windows this time around (I kept it at a minimal 20 gb to download any firmware updates only) but then encountered the issue. The prior install was done to be "alongside windows", by comparison. I'm guessing then, by your link, I might not be downloading the necessary drivers when Windows. – BayesIsBaye May 11 '20 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.